Autocomplete is too greedy with the mouse

10

I have a frustrating user experience problem in Linux; a common occurrence when using the notebook might go like:

  • I have, for some reason, used the mouse (e.g. to place the cursor) and then move the mouse pointer out of the way -- but muscle memory still places the pointer somewhere over the notebook
  • I use the notebook
  • At some point, I type in the full name of a function, but the autocomplete dropdown box opens under the mouse pointer, and whatever I typed gets replaced with whatever the mouse happened to be pointing at. (e.g. I type Sin[x] but get SinIntegral[x] because SinIntegral was under the mouse pointer when I typed [)

Is there an option to modify this behavior? e.g. so that a mouse click is required to get any pointer interaction with the dropdown box? (or, if necessary, to have autocomplete ignore the mouse entirely/)

user5147

Posted 2015-10-14T15:38:09.097

Reputation:

1Version/OS? Can't recreate this behavior on v10.2 Win 8.1. For me, as soon as I start typing, the mouse disappears if it's over the notebook window and is treated like it's not there. Even placing the mouse where I know that one of the dropdown options will appear does not highlight that option unless I move the mouse again after starting to type. – IPoiler – 2015-10-14T15:46:21.343

@IPoiler: v10.2 I think; I'm at home at the moment and use it at work, but it was that way last version too. – None – 2015-10-14T15:53:08.373

3I hate when this happens. And it happens a lot to me too since I also do most of my work on a Linux box. I am of the belief that it is particular to Linux bacause it seems not to happen when I'm on one of the other OS's. I don't suppose you also have cursor placement issues? I find that often when I want to add a character it shows up either one place to the left or right of where I thought it was being placed. Okay, enough griping for now. (And don't wind me up on cut-and-paste.) – Daniel Lichtblau – 2015-10-14T16:06:10.707

1@DanielLichtblau is "Flash cursor tracker when insertion point moves unexpectedly" an enabled option in your Interface<-Preferences? I don't have access to my Linux machine atm to check and I can't find it's name in the option inspector, but perhaps this may help with your characters showing up left or right of the intended target. – IPoiler – 2015-10-14T16:26:32.093

@lPoiler Yes it is, but thanks for raising the possibility. – Daniel Lichtblau – 2015-10-14T16:47:15.713

1I have this problem on linux as well. A working fix for me is to change "Enable autocompletion..." to something greater than 0 seconds because this problem only happens for me when I am typing quickly (or at least this is when it is most annoying) and I know the command I wish to use. 0.3 seconds seems to work well for me. – Jeremy Upsal – 2015-11-29T00:06:39.067

No answers