Customize startup

5

0

Is there a way to personalize the startup? I want, for example, that mathematica starts Maximized (not slightly-less-than-maximized as it usually does) with a notebook (also maximized) with a zoom of 130%. I use mathematica 8.0.4 and windows XP.

Zero

Posted 2012-05-05T17:56:00.007

Reputation: 697

Do you mean you want the new notebook to open in full-screen, or just as a maximized window? I think I know how to launch in real full screen mode on Mac OS X, but it involves Applescript, so it's platform dependent. What is your platform? – Jens – 2012-05-05T18:41:12.993

@Jens No need for applescript... SetOptions[SelectedNotebook[],WindowSize -> Full] does it :) – rm -rf – 2012-05-05T18:47:37.183

@R.M. Thanks - that's better. I just thought of scripting because I have one notebook that I always launch via Applescript, so I would have re-used that approach... – Jens – 2012-05-05T18:52:36.333

Answers

4

In MMA prefs / advanced/ open option inspector and you can set the values you want to customize. Full screen is under Window Size and select "Full". Zoom is under Notebook Options/ Display options/ Magnification.

R Hall

Posted 2012-05-05T17:56:00.007

Reputation: 4 190

1Selecting "Full" under Notebook Options/Windows properties/Windows size does nothing but the magnification worked well. – Zero – 2012-05-05T19:10:58.510

F12 or cmd/option/F will also give you full screen. – R Hall – 2012-05-05T21:36:47.137

4

I find it easiest to create a Notebook with the features I want, and then open that Notebook to launch Mathematica.

Save this code as a .nb file. If you want Mathematica to also open "Maximized" rather than in the slightly-less-than-Maximized form it usually does, also create a shortcut to this Notebook and change the properties to Maximized, then use that.

Notebook[{},
  Saveable->False,
  WindowSize->Scaled[1],
  WindowMargins->{{Automatic, 0}, {Automatic, 0}},
  Magnification->1.3,
]

Mr.Wizard

Posted 2012-05-05T17:56:00.007

Reputation: 259 163

If you tried the version with Editable->False and of course it failed, please try now. – Mr.Wizard – 2012-05-05T18:40:53.413

why Saveable -> False? Or is this your invisble notebook/ – rm -rf – 2012-05-05T18:48:12.080

@R.M Saveable -> False so that you do not accidentally overwrite this starting Notebook and have to create it again. Mathematica should still prompt you to save the file on closing. – Mr.Wizard – 2012-05-05T18:49:52.700

@Mr.Wizard Mathematica doesn't prompt me to do save the file on closing but when i open this notebook, it is in fullscreen mode and with the right magnification,as desired and what do you exactly mean with "change the properties to maximized". – Zero – 2012-05-05T19:38:08.537

2@Mr. Wizard in fact, the documentation says: A notebook with the option setting Saveable->False can always be saved using the Save As menu item, but does not respond to Save and does not prompt for saving when it is closed. – Zero – 2012-05-05T20:20:15.037

@Diego Indeed. I admit I didn't try this before posting (and made at least one careless error as a result) but I was sure I'd had the behavior previously of closing a notebook and being prompted to save, just as you get with Notebooks created with File > New > Notebook Either I misremember or there is another setting I'm forgetting. – Mr.Wizard – 2012-05-05T23:42:16.337

Given that the current answer may have dangerous side effects I suggest you delete it until you have sorted this out. – Sjoerd C. de Vries – 2012-05-06T08:40:30.433

What's dangerous about this? If the comments are outdated they should be deleted, they are puzzling/confusing/perplexing/flummoxing – Rojo – 2012-10-24T14:19:41.007

0

You could either edit the Default.nb notebook to fit your needs, or inherit from it to create another stylesheet, and set it as the default by changing $FrontEnd's DefaultStyleDefinition's option to that new notebook.

Rojo

Posted 2012-05-05T17:56:00.007

Reputation: 40 993