Bug in ListVectorPlot?

3

2

Trying to evaluate the following expression kills my kernel (Mathematica 8.0.0.0):

ListVectorPlot[{{{0.04039190555`,0.00897597901`},{0.1094840396`,-0.4878660114`}},{{0.01346396852`,-0.02692793703`},{-0.4484770638`,-0.2210618086`}},{{-0.01346396852`,0.02692793703`},{0.4484771099`,0.2210617151`}},{{0.04039190555`,0},{6.015064858999999`*^-7,-0.5`}},{{-0.04039190555`,0},{-8.376467958999999`*^-7,0.5`}},{{0.04039190555`,0.004487989505`},{0.05578099204`,-0.4968787387`}},{{0.04039190555`,-0.004487989505`},{-0.0557801133`,-0.4968788373`}},{{-0.04039190555`,-0.004487989505`},{-0.05578124893`,0.4968787098`}},{{-0.04039190555`,0.004487989505`},{0.05577990379`,0.4968788608`}},
{{0.03141592654`,0.004487989505`},{0.0717709292`,-0.4948221233`}}
}]

Is this a bug?

pawel_winzig

Posted 2014-05-26T08:46:39.633

Reputation: 1 487

Works for me on 9.0.1 Windows. – ciao – 2014-05-26T08:55:47.703

1It quits the kernel and doesn't output anything on v8.0.4. – Öskå – 2014-05-26T09:08:48.173

Also works fine for me, running V9.0.1 on OS X, – m_goldberg – 2014-05-26T11:09:41.793

It works at first on v10.0.2 on Windows 7 (64 Bit) but crashes if called again. – gwr – 2014-12-16T13:47:13.767

Answers

4

Still crashes the kernel in version 10.0.2. The reason seems to be that the points don't lie on a regular grid: The command

ListVectorPlot[
 Table[{{x, -y}, {-y, x}}, {x, -3, 3, 0.5}, {y, -3, 3, 0.5}], VectorPoints -> All]

works, but the command

ListVectorPlot[
 Table[{{x, -y + 0.01*x}, {-y, x}}, {x, -3, 3, 0.5}, {y, -3, 3, 0.5}], VectorPoints -> All]

crashes the second or third time it's called. Ron

RonH

Posted 2014-05-26T08:46:39.633

Reputation: 251

1I verified it. Same on my machine, 10.0.1 – Chen Stats Yu – 2014-12-15T21:03:04.617

1Same on 10.0.2 and Win 7 (64 Bit) – gwr – 2014-12-16T13:50:30.000

Verified also, 10.0.0.0 Linux x86 (64-bit) Ubuntu 18.04.4 – kl0z – 2020-07-01T11:28:40.253

0

enter image description here

MMA 10.0.1 X64 Win7.

Works fine. Glad it did not crash!

Chen Stats Yu

Posted 2014-05-26T08:46:39.633

Reputation: 4 816

But did you try to do it repeatedly? v10.0.2 crashes the second or third time it is called on Wind 7 (64 Bit). – gwr – 2014-12-16T13:49:18.927

In 10.0.1 X64 (Win7), I repeated 3 times. It was fine. – Chen Stats Yu – 2014-12-16T15:47:46.507