Problem enabling PlotLegends in Mathematica 8.0

2

I am trying to make a legend for a simple plot in Mathematica 8, but does not seem to recognise the command PlotLegends. I declared beforehand Needs["PlotLegends`"], and get this message:

Needs::nocont: Context PlotLegends` was not created when Needs was evaluated. >>

I also tried to install this pakage manually by going to File -> Install -> .... I am not very experienced with Mathematica, so an answer for dummies will be appreciated.

Polina

Posted 2013-10-09T13:18:13.873

Reputation: 21

Question was closed 2018-04-30T00:38:14.513

Perhaps you have spelled the name of the package incorrectly. You get the same error message if you use a lowercase l or a double backtick quote instead of a single one. – Sjoerd C. de Vries – 2013-10-09T20:20:58.527

Try in a "fresh" kernel. First evaluate Quit to quit the kernel. Then immediately, evaluate Needs["PlotLegends`"]. Do you still get this error message? If yes, your Mathematica installation is either broken, or you have accidentally installed something named "PlotLegends" into your $UserBaseDirectory which is conflicting with loading the package that is bundled with Mathematica. Evaluate $UserBaseDirectory to see where this location is, open it, and check that the Applications folder doesn't contain anything named PlotLegends. If it doesn't then try reinstalling Mma. – Szabolcs – 2013-10-10T00:19:28.173

No answers