VertexLabelStyle not found in Mathematica 8.0.0.0

2

I tried to use VertexLabelStyle, but seemed not recognized in my system with version number 8.0.0.0. Is this expected or I have missed something? From the online documentation page, I don't see this option was added after version 8.0.0.0; it just says "New in version 8".

Qiang Li

Posted 2012-02-21T21:17:52.447

Reputation: 1 061

Could you try Graph[{1 \[UndirectedEdge] 2, 2 \[UndirectedEdge] 3, 3 \[UndirectedEdge] 1}, VertexLabels -> Table[i -> Subscript[v, i], {i, 3}], VertexLabelStyle -> Directive[Red, Italic, 20], ImagePadding -> 20] in your version and see what you get? This works fine in version 8.0.4. What you are seeing may be due to some fixes between 8.0.0 and 8.0.4 – kglr – 2012-02-21T21:34:00.960

I also find it does not work in 8.0.0.0 – Eli Lansey – 2012-02-21T21:45:35.220

@kguler: it says Graph::optx: Unknown option VertexLabelStyle in – Qiang Li – 2012-02-21T22:15:34.823

Answers

2

VertexLabelStyle was introduced in Mathematica 8.0.1.

The online documentation does not differentiate between the 8.0.x releases, but the in-product documentation does and has no mention of VertexLabelStyle in 8.0.0.

ilian

Posted 2012-02-21T21:17:52.447

Reputation: 24 492

1

Collecting the suggestions in the comments above:

In version 8.0.4,

  Graph[{1 \[UndirectedEdge] 2, 2 \[UndirectedEdge] 3, 3 \[UndirectedEdge] 1},
  VertexLabels -> Table[i -> Subscript[v, i], {i, 3}], 
  VertexLabelStyle -> Directive[Red, Italic, 20], ImagePadding -> 20]

works fine. In version 8.0.0 it gives the error message

Graph::optx: Unknown option VertexLabelStyle in ...

So, most likely explanation is: another version 8.0.0 bug fixed in version 8.0.4.

kglr

Posted 2012-02-21T21:17:52.447

Reputation: 302 076