How do I "start a reference system"?

15

1

When I attempt to insert a citation or specify a database to use as a bibliography, I get a message that I need to "start" the "reference system" "manually":

enter image description here

I have no idea what a references system is, let alone how to start one ("manually" or otherwise). I've followed all of the steps in the documentation, to no avail.


If it matters, I'm running OS 10.8.2, using a BibTeX file (which I've used without issues in other applications, e.g. LyX) for my references, and I have a fill MacTeX installation in the standard locations on my machine.


UPDATE: It matters.

orome

Posted 2012-11-30T21:01:42.373

Reputation: 12 197

What about version 10? – ALEXANDER – 2014-10-21T11:49:44.853

Under OS X, if I choose a bib file, I get this. So I am guessing it doesn't work under OS X (although I would like to be wrong).

– acl – 2012-12-11T15:44:19.180

@acl: If I dismiss the the error dialog that I get when I first try to insert a reference, and then try to use the "Database" control at the bottom of the "Insert Citation" dialog, I get the same thing you get, in addition to a repeat of the error above. – orome – 2012-12-11T15:47:09.530

Answers

5

At last (after 2.5 months), an answer from Wolfram "support" regarding my problems with this feature, documentation (and repeated insistence from Wolfram notwithstanding):

It's only presently supported under Windows.

orome

Posted 2012-11-30T21:01:42.373

Reputation: 12 197

11

As explained in the section tutorial/CitationManagement you need to have EndNote or BibTeX for managing your citations. Interaction with both is covered in this tutorial.

Below is the result I obtained using the sample BiBTeX file downloaded here. Don't forget to work in a cell with the Text style (Alt-7 on Windows) when you use this, otherwise the necessary option will be greyed out.

Mathematica graphics

Mathematica graphics Mathematica graphics

I tried it both on Mathematica 8 and 9. Works without a hitch.

Sjoerd C. de Vries

Posted 2012-11-30T21:01:42.373

Reputation: 63 549

Does anyone know if Endnote support has been added for Macs in V9? – Mike Honeychurch – 2012-11-30T21:57:15.977

I can't find anything relevant there. What does "have" mean? I have a .bib file, what else do I need and how do I "start" it? All the reference says is "In the data source drop-down menu at the bottom of the Insert Citation dialog, choose BibTeX. A dialog will come up asking for you to choose the .bib file to be used for your reference database. Choose the .bib file and Mathematica will load the database. Once Mathematica loads the database, the references will appear in the Insert Citation dialog and you can insert them as in the above examples." But I just get the error above. – orome – 2012-11-30T23:02:44.163

@raxacoricofallapatorius See update. You have used the wrong entry in the submenu. You should not use the rebuild option. – Sjoerd C. de Vries – 2012-11-30T23:31:00.733

@SjoerdC.deVries: I'm impressed that you knew that — but no, in fact, I chose "Insert Bibliographical Reference..." (as I say in the question). And get the error message, even before I can get at the dialog. If I dismiss the error and forge ahead, then when I set my .bib file (e.g the sample), I get the error again. – orome – 2012-11-30T23:39:37.107

@raxacoricofallapatorius Please reread your question. You said no such a thing. The picture you included suggested to me that you had used the rebuild reference option (the 6th option in the sub-menu; see the new picture I now included). If this is not the case, and you were working from a text cell I suppose this might be an installation error. Could try installing again (takes 10 min; I know, just did it yesterday ;-( ) – Sjoerd C. de Vries – 2012-11-30T23:57:39.313

So this should work without any additional steps on my part, right? I don't need to have anything else installed or running? (If so it must be some kind of installation error.) – orome – 2012-12-01T00:15:11.620

@raxacoricofallapatorius I hadn't used any citation stuff on this PC before working on this question. I just downloaded the .bib file. That's all. The doc page says something about a plugin for EndNote, that's why I presume the installation phase may be crucial. At least, if you're using EndNote, but perhaps the same holds for the BiBTeX route. – Sjoerd C. de Vries – 2012-12-01T00:18:43.667

And you don't have anything else running in background that or on a path that might be providing some BibTex services? – orome – 2012-12-01T00:21:51.647

@raxacoricofallapatorius I stopped using Tex/LaTeX about two decades ago. So, no. – Sjoerd C. de Vries – 2012-12-01T00:23:33.047

Several complete reinstalls and reboots have no effect. – orome – 2012-12-03T14:47:29.703

1@raxacoricofallapatorius I have tried it now in both v8 and v9 and it works without problems. I noted that a helper program is started as soon as you are going to use citations. It's called BibTeXLink. I can imagine this is installed as an optional extra during installation and you didn't select to install the extras. Can you positively confirm that the text cursor is blinking in a text-style block (Alt-7) when you open the citation menu? Furthermore, did you select the "Bibliographical Reference..." sub-menu item, the first item shown in the picture above and not any other item? – Sjoerd C. de Vries – 2012-12-03T20:55:11.877

1@raxacoricofallapatorius Paths for BibTeXLink: 1) c:\Program Files\Wolfram Research\Mathematica\8.0\SystemFiles\FrontEnd\Binaries\Windows\BibTeXLink.exe 2) c:\Program Files\Wolfram Research\Mathematica\8.0\SystemFiles\FrontEnd\Binaries\Windows-x86-64\BibTeXLink.exe – Sjoerd C. de Vries – 2012-12-03T20:56:16.807

I've installed extras, but the only things listed there are the browser plug in and Spotlight support. Yes: text and "Bibliographical Reference...". – orome – 2012-12-03T21:25:40.663

Nothing like that for me in ~/Library/Mathematica/SystemFiles/FrontEnd or /Library/Mathematica/SystemFiles/FrontEnd or anywhere in the Mathematica package. – orome – 2012-12-03T21:29:24.867

@raxacoricofallapatorius This is the first time you mention you're on OSX. Probably should mention that in your question. You could try to see if another mac/mma owner can provide you with said file. I'm on Windows, so can't help you any further I'm afraid. – Sjoerd C. de Vries – 2012-12-03T21:34:31.087

2

I just found out with the BiBTeX example file, that this one is working under Windows in MM 8. But the BiBTeX file generated by Mendeley Desktop 1.7.1 does not!

Even if I removed the header comment from that file, MM refused to display the entries. Then I removed the file attribute from the entry. Now it is working.

The faulty path export looked like this: file = {:D\:/Dropbox/Literature/2005/Solid-State Electronics/Romanjek et al. - 2005 - Characterization of the effective mobility by split C(V) technique in sub 0.1$\mu$m Si and SiGe PMOSFETs.pdf:pdf},

Now I have to figure out, how to get rid (automatically) of these path entries. The use of the title in the PDF name is quite convenient for the manual search online, but here it causes the trouble.

Frank

Posted 2012-11-30T21:01:42.373

Reputation: 323

When I do all steps written in the tutorial to insert citation on my PC, (WinXP, Mathematica 9.0.1, EndNote 9), the dialog "Insert citation" comes up empty and after at least 5 minutes of a hang up. Looks as if the plug-in was not installed. I have installed the M 9.0.1 version on my machine well after the installation of the EndNote. Should it be another way around? May it be that the option only works with the EndNote X? – Alexei Boulbitch – 2013-02-13T09:12:27.707