Bitcoin explorers don't show my addresses transactions

0

I'm creating bitcoin addresses for a wallet we're building. To make sure the addresses are valid I went to a couple of bitcoin explorers and they reported, correctly, that the address does not have any transactions yet.

Great. But now I put in a couple of addresses from my existing wallets (Bread and Jaxx) which both have several transactions over the past year or so. Once again the explorers reported -- this time incorrectly -- that the addresses have no transactions.

The explorers I tried, with an example address that has transactions associated with it:

www.blockchain.com/btc/address/1LQs3i94JTJGimr2BiM929Zdhm1ShCatJR 

insight.bitpay.com/address/1LQs3i94JTJGimr2BiM929Zdhm1ShCatJR

Why can't I see the transactions for this address?

Eddy

Posted 2018-09-03T07:50:38.127

Reputation: 103

Answers

0

Check that this is the actual address that you used to receive the Bitcoin in the past.

The default behavior for wallets is to generate a new address each time you want to receive funds. This means that if you simply opened your wallet, hit generate, and tried to scan that address, it will show 0 transactions. And, this is correct, because even though the wallet has received Bitcoin, that specific address hasn't.

Tanner.R

Posted 2018-09-03T07:50:38.127

Reputation: 176

If anyone is seeing this question, the answer is correct. Read about bip39 and bip44 to learn about this issue. – Eddy – 2018-09-04T11:50:16.370