Why can't the genesis block be found I create an altcoin?

0

I have built the bitcoin source code with a new pszTimestamp, hashGenesisBlock and hashMerkleRoot

The code builds fine and does not run into any assert problems when validating these hashes on [line 128 and line 129 of chainparams.cpp]. (Great)

However...

When I run bitcoin-qt I run into the error below:

Error: Incorrect or no genesis block found. Wrong datadir for network?

Potential Cause:

Is the reason I am encountering this error because I have not yet mined the genesis block? If so how do I do that? It seems that in the bitcoin code there is nothing about mining the genesis block. I have heard rumours that this functionality was removed and that I will have to download a separate program for this step. Please confirm.

Oscar Chambers

Posted 2017-11-14T07:57:50.737

Reputation: 215

I met same problem. I met CBlockDiskPos(nFile=0, nPos=8) error or AcceptBlock: high-hash, proof of work failed (code 16) error. Have you solved? Any updates? – creator – 2018-03-01T07:42:24.963

Answers

0

Thant is correct. You have to mine the genesis block first separately if you are compiling the most recent bitcoin codebase.

Checkout : https://github.com/vlamer/genesis-block-generator

Laksh Gandikota

Posted 2017-11-14T07:57:50.737

Reputation: 16

Is it still work with newest litecoin source? (0.15.1) – creator – 2018-03-01T08:14:38.133

I'm not entirely sure of that but since its a complete copy of bitcoin source, I don't think anything would be different. – Laksh Gandikota – 2018-08-14T21:16:42.713