Compiling litecoind on Ubuntu 15.04

3

I am trying to compile litecoind on Ubuntu 15.04 and I stuck here:

/litecoin/src$ make -f makefile.unix USE_UPNP=-
make: makefile.unix: No such file or directory 
make: *** No rule to make target 'makefile.unix'.  Stop.

I found some a little bit different ways to compile litecoind, but every time I have problems with "makefile.unix". Can someone help me?

Pavlo Karataiev Yozh

Posted 2015-07-02T13:07:09.510

Reputation: 31

Answers

3

The build system has changed to autotools in later versions of Litecoin.

The process now looks like this:

./autogen.sh 
./configure
make -j4 
make install # optional

There's up to date instructions in detail in build-unix.md.

Anonymous

Posted 2015-07-02T13:07:09.510

Reputation: 12 846

What difference does it make if I don't do make install ? Why is it optional? – rineez – 2017-12-17T16:42:43.580

You might not want the binaries to be anywhere but the build directory. – Anonymous – 2017-12-18T03:23:42.430

is that a reply for my comment above? – rineez – 2018-01-09T07:48:14.870

1Yes. You don’t need to make install because that moves the binaries, which you might not want. – Anonymous – 2018-01-10T01:46:32.517

1

You have to be on your unix src dir where the file located and then open the src dir with the terminal and then

./autogen.sh 
./configure
make -j4 
make install # optional

Vistor

Posted 2015-07-02T13:07:09.510

Reputation: 11