Error While making windows.exe using gitian build?

1

0

Actually I'm making a logos windows exe (logosd and logos-qt) following the release process, which is mention on below path on any coin you can find that path, I'm working logos LGS Coin that's why I'm mentioning.

logos/contrib/gitian-descriptor/README

# Build Win32 dependencies: These three command successfully completed and generated a zip file

./bin/gbuild --commit logos=HEAD ../logos/contrib/gitian-descriptors/boost-win32.yml
./bin/gbuild --commit logos=HEAD ../logos/contrib/gitian-descriptors/deps-win32.yml
./bin/gbuild --commit logos=HEAD ../logos/contrib/gitian-descriptors/qt-win32.yml

But when I run below mention command it will give me error

# Build Win32 release:

./bin/gbuild --commit logos=HEAD ../logos/contrib/gitian-descriptors/gitian-win32.yml

Error

/home/ubuntu/build/logos/src/leveldb/libleveldb.a: could not read symbols: Archive has no index; run ranlib to add one
collect2: ld returned 1 exit status
make[1]: *** [release/logos-qt.exe] Error 1
make[1]: Leaving directory `/home/ubuntu/build/logos'
make: *** [release] Error 2

I've search on internet found that execute these command ranlib libleveldb.a and it will compile, but still I'm getting same error again and again. So please let me know how to resolve that issue.

My System is ubuntu 14.04 64bit architecture.

Prabhat Chauhan

Posted 2015-04-10T13:34:08.797

Reputation: 11

Did you try these debugging steps? http://stackoverflow.com/questions/2765240/could-not-read-symbols-archive-has-no-index-run-ranlib-to-add-one

– Nick ODell – 2015-04-10T15:22:31.577

Yes, I have tried these debugging steps, But still it will show me the same error. – Prabhat Chauhan – 2015-04-13T07:11:35.357

Hey guys, still any solution? im using ubuntu 16.04 and cant break this point. src/leveldb/libleveldb.a: could not read symbols: Archive has no index; run ranlib to add one – Petr Latal – 2018-01-26T11:21:49.403

No answers