How can I enable more GPUs in Ubuntu for poclbm?

4

I have an Ubuntu set up (11.10) and 2 ATI Radeon HD 6870 cards. It detects one, but not the other for some reason when I try to run poclbm.

When I run lspci, it finds both cards.

Any help?

Shamoon

Posted 2012-03-09T19:24:20.783

Reputation: 2 749

Try the command display=:0 . – Meni Rosenfeld – 2012-03-16T06:09:51.440

Maybe this is not going to help you, but... Ubuntu is a distribution strongly oriented towards casual users, are you sure it's a wise choice to use it for mining? Couldn't you just use, for example, debian? – o0'. – 2012-04-04T22:43:15.170

Answers

2

lspci lists PCI devices. ./poclbm.py lists OpenCL devices. If the former finds the device but the latter does not, your second GPU must not be registering as an OpenCL device.

Ubuntu 11.10 has a notorious reputation for multiple-GPU bugs. (See here and here.) I personally have had issues with 11.10 mining that were resolved simply by switching to another release. I would suggest you instead use Ubuntu 11.04 (Natty Narwhal); it is generally regarded to be the most reliable Ubuntu version for mining.

If that is not an option, or installing 11.04 doesn't fix the problem, try the following steps:

  1. Uninstall whatever version of Catalyst/SDK you have (make sure to remove all configuration files) and install Catalyst 11.6 and SDK 2.4.
  2. Run aticonfig -f --initial --adapter=all again. Make sure it runs without errors.
  3. Run aticonfig --list-adapters. You should see two.

Those steps should fix any configuration issues. If your problem persists, it's either a hardware issue (or an Ubuntu 11.10 issue).

BinaryMage

Posted 2012-03-09T19:24:20.783

Reputation: 1 346

-2

Try not booting into graphical mode at all, just command line. Leaving compiz/gnome/gdm/drivers off should alleviate most confusion, as the cards should both be in default modes (and one in VESA/VGA) and for the most part will be untouched by system specifics (more like normal PCI devices)

Colin Godsey

Posted 2012-03-09T19:24:20.783

Reputation: 107

Unfortunately, that won't work; ATI OpenCL under Linux requires an X server running. – BinaryMage – 2012-04-05T01:34:40.740