How do you install cgminer on ubuntu

2

1

I have downloaded cgminer for linux and uncompressed it and tried to run it but clicking on the executable file does nothing it is marked as executable and still does not run. Is there something else I should do?

I tried to open this file:

File I tryed to open

Edit: Here is a screenshot from the directory cgminer is in from the "ls" command

enter image description here

Qwertie

Posted 2013-12-21T22:58:18.017

Reputation: 165

Thank you for the screenshot. I'm installing Ubuntu on a Virtual Machine to look into the issue. – rrrrrrrrrrrrrrrr – 2013-12-22T09:24:03.543

I could download, compile and run cgminer with the steps described in my answer without any problem. Did you download the binaries or did you compile it from the source code? – rrrrrrrrrrrrrrrr – 2013-12-22T09:44:09.910

I downloaded the binarys – Qwertie – 2013-12-22T10:23:29.913

Can you link me the package? – rrrrrrrrrrrrrrrr – 2013-12-22T15:15:45.610

http://ck.kolivas.org/apps/cgminer/ I have " cgminer-3.8.5-x86_64-built.tar.bz2" – Qwertie – 2013-12-22T22:32:04.300

It works for me, I ran out of ideas... – rrrrrrrrrrrrrrrr – 2013-12-22T23:08:02.403

the accepted answer is correct but i would not sudo it – None – 2016-08-17T03:17:20.187

Answers

2

cgminer is a command-line software.

Open a Terminal and change the working directory to where you have your cgminer executable with the cd command. For example, if you have it on the Desktop you have to use the following command: cd ~/Desktop (where ~ indicates your home directory).

Then, if necessary, mark it as an executable file with the chmod +x cgminer command and finally run it with the ./cgminer command. Note that you will probably need to run it as the root user, so you probably want to run this command instead: sudo cgminer.

You can also specify command line options. For example, if your pool URL is http://foobarpool.net:3333, your username is qwertie.1 and your password is 1234 you can run cgminer with the following command so it is preconfigured and will start working right away: sudo cgminer -o http://foobarpool.net:3333 -u qwertie.1 -p 1234.

You can also specify lots of options for the GPU, fallback mining pools and other things. For a complete list, use this command: cgminer --help.

rrrrrrrrrrrrrrrr

Posted 2013-12-21T22:58:18.017

Reputation: 474

1This gives me sudo: cgminer: command not found – Qwertie – 2013-12-22T00:09:44.057

1Are you in the right directory? Where is your cgminer executable placed? Did you use cd correctly? – rrrrrrrrrrrrrrrr – 2013-12-22T00:11:23.697

1cgminer is under home/Apps/cgminer. Here is the line from the terminal "/Apps/cgminer$ " – Qwertie – 2013-12-22T00:14:08.543

1Try to run the ls command in that directory. Does cgminer show up in the list? – rrrrrrrrrrrrrrrr – 2013-12-22T01:00:04.287

1yes. I even copied/pasted cgminer from ls to make sure I spelt it right, still go the same result – Qwertie – 2013-12-22T01:13:51.523

1Does it work if you run just cgminer alone without sudo? – rrrrrrrrrrrrrrrr – 2013-12-22T01:23:15.963

1I still get command not found – Qwertie – 2013-12-22T01:26:05.243

1Then you are not in the right directory. Can you please provide me with a screenshot of the result of the ls command? – rrrrrrrrrrrrrrrr – 2013-12-22T01:32:09.057

1

Go to the directory of cgminer.

Type

sudo -s

Type your password

Type

chmod +x cgminer

Type

./cgminer --help

Aazar Khan

Posted 2013-12-21T22:58:18.017

Reputation: 11