Why is my print displacing along the y-axis by 2-3 cm?



I am encountering a problem with this ID3 printer using ABS -- at some point during the print the print head displaces on the y-axis by 2-3 centimeters. I cannot pinpoint how or why it is doing this. It has displaced in the positive Y direction and in the negative Y direction on separate runs of the same piece (which is just a poker chip I found on Thingiverse).

Is this a software issue (Simplify3D) or a hardware issue? Can anybody suggest a fix?

See the following photos:

3D print exhibiting positive Y displacement mid-print

Close up of 3D print exhibiting positive Y displacement mid-print


Posted 2016-03-30T18:29:59.650

Reputation: 173



I had exactly the same effect when my stepsticks where overheated. So my solution was to add cooling fan and reduce current on stepsticks. Of course heatsink is obvious.

Please note that different axis requires different current settings. For example, in Prusa and clones, X and Y need a bit less current as one stepstick controls one motor but Z axis usually uses 2 motors connected to 1 driver.

darth pixel

Posted 2016-03-30T18:29:59.650

Reputation: 3 363

So far, this seems to be the pertinent issue. I was able to complete multiple prints with no displacement problems by rigging a fan to blow on the step sticks. I'll still need to find a more permanent solution than what I've kluged together, but this is working! – CuriouSir – 2016-04-01T23:39:11.333

i've added frame to set cooling fan permanently on a side of PCB – darth pixel – 2016-04-02T06:57:20.260


This has happened to me in the past and here are a few things that I determined could have been the cause:

  • Limit Switch triggered. My coworker was able to repeat the issue by manually triggering a limit switch during the print. Somehow, this seemed to cause the relative axis to shift on his MakerBot Replicator 2.
  • Skipped steps. It's possible that, if stalled due to excessive load, the stepper motor could skip steps. I have a dual extruder, so if a part curls really bad then the second nozzle gets caught in the print. I'm not sure exactly how this works, but my coworker suggested this as an issue.
  • USB connection. I had sliced a model and tried printing over USB connection, however each time I attempted the print I encountered the "shift" at the same exact location. However, using the slice, I exported a G-Code file and printed from the machines SD card with no errors.
  • Slicing Engine bug. This is in correlation to the USB connection issue. I noticed that the issue occurred after updating my slicing engine. My solution in the long term was to re-install the previous version that was stable for me. I was using MakerWare 2.4.2 and reverted back to MakerWare 2.4.1.

If you're printing via USB connection, I'd suggest exporting to G-Code if you're able to print via SD Card until you can find a stable version of software for your machine. This has been the most repeatable solution for me in the past.


Posted 2016-03-30T18:29:59.650

Reputation: 6 144

I tried printing directly from a microSD card -- still had the problem. Slowly ruling out options... – CuriouSir – 2016-04-01T19:29:30.620


It seems unlikely this is a software or G-code issue, instead it appears your Y-motor is occasionally missing some steps. There are two possible causes for this:

  • The current limit for the stepper driver is set too low, limiting the amount of torque the motor can generate. When the printhead encounters some resistance (for instance due to running into a blob on your model) the motor skips steps, resulting in a displaced model.

  • The current limit for the stepper driver is set too high. The stepper driver will overheat and thermal protection will shut it down temporarily. Some steps are lost while it is shut down.

There are various ways to calculate the ideal current for a motor and set it using a multimeter, but a simpler approach is to turn it way down, and then slowly turn it up. Turn it up just beyond the point where the axis moves reliably.

Tom van der Zanden

Posted 2016-03-30T18:29:59.650

Reputation: 14 003

Thanks for the suggestion, I'm trying the other things (SD card, stepstick cooling) first because I honestly have no idea how to adjust the current limits. I presume this is a setting I cannot change in the software? – CuriouSir – 2016-04-01T19:16:38.787

The current limit can be adjusted on most stepper motor driver boards. It is a potentiometer on the board (you should see a separate board for each axis/extruder). – tbm0115 – 2016-04-01T19:34:37.310


In my case the solution was to use Slic3r instead of Cura. Cura has some issues.


Posted 2016-03-30T18:29:59.650

Reputation: 19

1This has nothing to do with the slicer used (but perhaps decreasing the speed/acceleration in the slicer might help, but that's not specific to cura/slic3r) and is almost certainly a stepper driver/mechanical issue. "Some issue" is very vague, care to elaborate? – Tom van der Zanden – 2016-11-21T21:29:53.067

1@zoomtronic It is recommended to elaborate on your answer as it currently considered a "lower quality" answer. To improve your answer, consider expanding on what "issues" Cura has and why it didn't work for you as well as how slic3r was an improvement for the situation. – tbm0115 – 2016-11-22T20:44:41.817