Bed Heating Failed, Printer Halted, Please Reset

1

A couple of weeks ago I have successfully built a 3D Printer and Printed an XYZ Calibration Cube with ABS material at bed temperature 80 °C.

Next Day I tried bed heating at bed temperature 80 °C,

Screen is blank

and it's not heating at all and showing Following error.

Bed Heating Failed Printer Halted Please Reset

Specification board

I use a RAMPS 1.4 running Marlin 1.1.X

Troubleshooting

I searched on Google and tried possible solutions but they are not working.

  1. I changed the thermistor and nothing happened, the old thermistor is also showing the same temperature.
  2. I connected 12V Supply Positive to SMPS (Switched-Mode Power Supply) and Negative to RAMPS 1.4 and not working
  3. I checked the Voltage at heat bed it's showing zero in spite connecting to SMPS

Please let me know how can I fix the problem?

I have blank image after pressing 80 °C

Mallikarjun Talagade

Posted 2019-02-04T13:32:22.127

Reputation: 11

I have installed Marlin 1.1.x firmware.

When It's powdered it'll display properly but when I select Bed Heating Option It becomes like a shown in the image and after 30 to 50 seconds later it displays message Bed Heating Failed Printer Halted Please Reset

Except Bed heating everything working fine – Mallikarjun Talagade – 2019-02-04T18:47:18.207

1What happens if you set Bed Temp to, say, 40 Degrees C? Does it warm at all before throwing an error? – Carl Witthoft – 2019-02-04T20:25:31.710

No, Warming. The LCD Temperature won't change at all from Room Temperature i.e 25 Degrees Celcius. – Mallikarjun Talagade – 2019-02-05T01:56:40.313

Why not attach your PSU directly to the bed, will it warm up? If it does the bed is working then check cables, connectors of the setup. – 0scar – 2019-02-05T11:00:01.530

When I connect Heated Bed directly to SMPS it's working but when I connect it to RAMPS board it's not working and the screen is becoming blank – Mallikarjun Talagade – 2019-02-12T07:39:15.757

Answers

2

Check that your heated bed is still working:

  • Measure the resistance of your heated bed. It depends an the power rating of the bed, but 12V beds usually have values <3 Ohms. That's hard to measure for cheap multimeters, but you just need to check that it's not MOhms which would indicate a broken heated bed.
  • Your heated bed could also have a short. That's hard to measure, as <3Ohms are already 'almost a short'. You'll only notice because your bed will not get warm, but the wires, connectors and elements on the RAMPS will get even hotter. Marlin should detect this and switch off after a few seconds.
  • Check your thermistor. Seems you already did that.
  • Check your RAMPS by measuring the voltage on the bed connector while setting the bed to heat up. You should see 12V, at least in the frist few seconds.

Chaos_99

Posted 2019-02-04T13:32:22.127

Reputation: 121

Heated Bed is working. when I connect directly to 12V SMPS but it's not working when I connect it to RAMPS 1. 4 – Mallikarjun Talagade – 2019-02-08T01:49:53.770