What triggers Marlin's "Click to resume..."?


I have a long print that keeps aborting. At some random point mid-print the printer says "Click to resume...". There is nothing in the G-code that asks for user confirmation. What could it be that triggers this? I noticed that sometimes (not every time) there is a blob of plastic in the way that should not be there.

On one occasion, after the "Click to resume...", the LCD showed the message FY178.N16466 and again waited for a click.

The printer is an Anet A8 with Marlin 1.1.9. Slicer is Cura. I am printing via USB from Cura directly.

This is the error message:

"Click to resume..." error message

Till B

Posted 2018-10-21T14:21:50.823

Reputation: 285

Do you have an M600 color change operation in your g-code? An M600 will cause the extruder to eject the current filament by reversing the extruder motor for a distance, like 100mm, then it displays a message like yours waiting for you to load the new filament; after you click it advances the filament and resumes printing. – John Deters – 2018-10-23T03:16:59.657

@JohnDeters No, that is not in the g-code – Till B – 2018-10-23T10:18:33.147

2I observed this too in 1.1.9 when a PC is connected via USB. I think this must be a bug. – dgrat – 2018-11-05T12:03:05.917

I don't know if this helps but Newbie issue mentions the same issue

– Greenonline – 2018-11-06T03:08:57.940

1It appears to be a problem between Ultimaker Cura 3.4+ and Marlin Firmware 1.1.8+, where Cura sends too many M105 commands (without waiting for an OK) causing the buffer of the printer to overflow, see my updated answer. – 0scar – 2018-11-06T07:19:29.243

Not yet found time to check. It is a six hour print and I have been on a couple of business trips, so unfortunately not so much time for tinkering around. But I will certainly accept the answer that solved the problem – Till B – 2018-11-12T07:15:41.377

@TillB Ultimaker Cura 3.6 is out now, please try to see if it fixes your problem and accept an answer, thanks! – 0scar – 2018-12-03T10:47:38.913

Yes, I use Cura 3.6 already. I am now happy to say that the print lasts long enough to produce secondary problems (layer shifting, presumably due to overheating stepper drivers). I am working on it. – Till B – 2018-12-03T18:53:31.237



To answer your question directly, this action (Click to resume...) is triggered by a buffer overflow of the Marlin firmware that is caused by the repetitive sending of M105 command by Ultimaker Cura (without checking the result).

This problem is a reported problem and fixed in the next release of Ultimaker Cura (please do note that as of posting this answer, the 3.6 Beta release is available for download). It appears to be a communication problem between Ultimaker Cura 3.4+ and 1.1.8+ versions of the Marlin firmware and has to to with polling of the temperature (M105). The link above also states it is fixed in the 3.6 release (which is the next release) as the fix has been integrated in the main code base.

This describes the problem:

To update the temperatures in the monitor, Cura sends M105 pings every 2 seconds. It seems that if this is done during a print without waiting for an OK from the printer, the serial buffer on the printer may still overflow eventually (causing Marlin to complain/pause).

and this describes the solution:

During some operations, such as preheating, the printer responds to new commands with echo:busy. While it is busy, it does send temperature messages, but these are not prepended with an ok, because the ok is supposed to show that a command was received and executed. So the two patches I wrote do the following:

  • the pattern matching no longer looks for ok messages, but looks for temperature updates (this fixes the temperature updating while the printer is preheating)
  • once the printer has said that it is busy, stop asking for temperature updates until the next ok is received (this prevents the serial buffer overflowing while preheating)

Old answer centered around the firmware (based on the text of the OP, no photo with the actual error message was added yet):

The text click to resume print cannot be found (with case insensitive search) in the latest sources of Marlin 1.1.9 down to Marlin 1.1.6. This means that you are using a different fork, an older version of Marlin or the message is not displayed as such.

The text message Resume print can be found, and is part of the message constant MSG_RESUME_PRINT

#define MSG_RESUME_PRINT                    _UxGT("Resume print")

But, this cannot be found in some sort of a concatenation using MSG_RESUME_PRINT!


Posted 2018-10-21T14:21:50.823

Reputation: 25 570


This is not an answer/explanation per se, but it might help you track down the cause.

It might be worth enabling logging M928 to the SD card (ensure that the R/W tab on the SD card is set appropriately), so that (after this has happened a few times) then you can look through the log to see what the command preceding the abort was, and if it is consistently the same (sequence of) commands that cause this to happen.

M928 filename

If that doesn't throw up anything obvious, then, in conjunction with logging, you could enable debugging, see M111 Debug level. For example:


Then run through the long print again. As before, after a few of the click to resume print messages, then go back and check the log for anything that might indicate why this is happening.

To subsequently disable the debugging:

M111 S0


Posted 2018-10-21T14:21:50.823

Reputation: 5 004

1I'm curious to know whether this error is reported, nice addition! – 0scar – 2018-10-23T23:06:58.773

1unfortunately, logging does not work. When executing the M928 command, it shows the filename in the display, nothing else happens. When resuming the print, manually, the printer hangs. The resulting file on the sd card is empty. – Till B – 2018-11-04T09:36:18.483

@TillB - Hmmm, that doesn't sound right... – Greenonline – 2018-11-04T11:25:29.150

I put the M928 into the gcode right at the beginning. Is that correct? Or should I rather put it somewhere later or send it via USB? currently it is executed right after preheating – Till B – 2018-11-04T11:41:12.217


For your information, this problem has occurred for me with Cura 3.6.0 (yesterday and 2 days ago)

I thought the problem was occurring with Marlin since 1.8.

My Marlin version is 1.3 (... just discover that because of that issue!)

As my printer works perfectly with 1.3, I'd prefer not to upgrade.

I had the 'click to resume' problem twice.

I've printed tons of ABS models without problem, two days ago, I've printed PLA models and had this issue. (70 °C 200 °C).

For sure if the problem occurs again, I'll upgrade to Marlin 1.9 (or even 2.0 even if still in beta) because it seems that you have found the problem and already solved it; I was surprised to read that it was fixed in Cura 3.6 since I had the problem with that version.

My printer is a Tevo Tarentula (modified, I've removed the pseudo bed leveling options because I prefer to level manually (no z move while printing)).

One more information is that in parallel, I've decided to print the first layer at a very low speed (adhesion problems).

I've changed from 30 mm/s (ABS with big adhesion problems) to 10 mm/s with PLA + Cura 3.6 and went into this bug (yes one could argue that I may print faster etc., but that's not the point here). Maybe I have the problem because I'm printing the 1st layer at a this slow speed (thus making the full buffer problem more critical).

The bug does not occur each time I print, even when printing the same model with same parameters...

@HuguesDug reported the same problem 14 days ago and @Leeb answered him that running with Marlin 1.9 solved the problem.


Posted 2018-10-21T14:21:50.823

Reputation: 21

2This seems more like a bug report (or me too answer) and not an actual answer with a solution - would that be a correct analysis? – Greenonline – 2018-12-01T02:53:35.683

You're right Greenonline, I wanted not to bug report since I have an old version of marlin and was imho too soon to report anything without searching more by myself. More again, the bug has been 'solved' and the reason was clear to me so reporting the same bug again would have been imho a waste of time for developpers. I've edited my post few minutes ago to answer myself : upgrade to marlin 1.9 should solve the problem. If not, then I'll open a report. Anyway, feel free to remove my post if that's sounds to you as noise :-D – HSaturn – 2018-12-01T09:54:16.273

1Me-Too reports that don't contain an answer are not what we try to strive for on the stack. Open a new question, if you have a similar problem, make an answer, if you solved your similar problem. – Trish – 2018-12-01T11:18:07.433

Thanks for providing the update. The answer makes more sense now, thanks. Also, Hi and welcome to SE.3DP, BTW. :-) – Greenonline – 2018-12-01T14:24:42.727


Tonight I had faced the same problem.

I've read somewhere (can't find the source now) that this is a Cura bug that has been fixed in Cura 3.6 beta

divest divest

Posted 2018-10-21T14:21:50.823

Reputation: 11

1If you can find the link, that would make your answer very useful. Maybe search your browser history? – Greenonline – 2018-11-06T02:54:31.370

According to this page for 3.4beta, For a full rundown of bug fixes, open Ultimaker Cura 3.4 beta and navigate to Extensions > Changelog > Show changelog. The page for 3.6 beta doesn't mention much, and I can't find the full list of fixes.

– Greenonline – 2018-11-06T03:04:33.590

@Greenonline It is an interfacing bug between Ultimaker Cura 3.4+ and 1.1.8+ Marlin, see my answer

– 0scar – 2018-11-06T07:24:20.597

@0scar - Ah ok, nice catch, well done :-) – Greenonline – 2018-11-07T17:02:45.013