How to change E0 to E1 on Marlin 1.1?


I have the same problem as this person but I don't have those lines in my RAMPS.h file as seen here.

I've recently burnt my potentiometer on E0 so the motor isn't working properly anymore. I want to use it on E1 instead. If you have any better idea how to fix this instead of changing code in firmware, feel free to share.

Ilya Smirnoff

Posted 2018-04-19T15:13:05.347

Reputation: 69

Your link is sort of broken, as is the link in your post on thingiverse. Instead of pointing to a particular post, your are pointing to a general forum, and it is hard to see to which post your are actually referring. Please edit your post(s) and fix the URL, as your question will probably be of more help someone else, with the correct link to the other person's issue. Do you mean to refer to this post: Switch E0 to E1?

– Greenonline – 2018-04-19T17:59:49.827

In addition, if you refer to an external website, please quote the relevant details of the issue [external post] here, as the external link could die (as most links tend to do), and then some/most of the information, that pertains to your question, will be lost. Thanks and welcome to SE 3D Printing... :-) – Greenonline – 2018-04-19T18:05:20.947

It is pretty easy ;) to adjust the pins in the firmware, I already described that for somebody that wanted to use the E1 as X, please look at my answer of".

– 0scar – 2018-04-19T18:14:34.097

It is MKS, but mks file refers to ramps file so i use pins_ramps.h – Ilya Smirnoff – 2018-04-20T14:02:08.070

@0scar still can't get it to work properly :( I've made neccesary changes in code, but now there is some problem with AVRDUDE

– Ilya Smirnoff – 2018-04-22T15:13:55.227

As said before, this has nothing to do with the code changes, it has something to do with your computer or Arduino setup. Look up some instructions on the web to upload firmware to your board, there are loads to find. – 0scar – 2018-04-22T21:44:43.667

@0scar so it might be that my arduino is now "bricked"? I have another Uno and it works just fine, but not this one – Ilya Smirnoff – 2018-04-23T14:30:42.053

No, it's not working. The arduino that is working is arduino uno and it is not for printer – Ilya Smirnoff – 2018-04-30T06:56:23.403



Another posting already discusses how you can change the pins to use spare stepper controllers for broken controllers by changing the pin layout. Assuming you are using a RAMPS board and using Marlin firmware, you should look at the pins_RAMPS.h file.

This file requires changes to address E1 to E0 and vice versa, please edit the file so that:

#define E0_STEP_PIN        26
#define E0_DIR_PIN         28
#define E0_ENABLE_PIN      24
#define E0_CS_PIN          42

is changed to:

#define E0_STEP_PIN        36
#define E0_DIR_PIN         34
#define E0_ENABLE_PIN      30
#define E0_CS_PIN          44

and also change:

#define E1_STEP_PIN        36
#define E1_DIR_PIN         34
#define E1_ENABLE_PIN      30
#define E1_CS_PIN          44


#define E1_STEP_PIN        26
#define E1_DIR_PIN         28
#define E1_ENABLE_PIN      24
#define E1_CS_PIN          42

When the file is changed an saved, build and upload code to your board and plug the connector of the E0 stepper into the E1 header.


Posted 2018-04-19T15:13:05.347

Reputation: 25 570

I've done that already. But now i have a new problem. The new firmware doesn't want to install and arduino IDE throws an error

– Ilya Smirnoff – 2018-04-20T05:35:53.823


the fastest way is to slice using two extruders and assign all print work to E1. Set the head offsets to [0,0] and that shall do the job.

The harder is to edit pins file and do remapping.


Posted 2018-04-19T15:13:05.347

Reputation: 1 900

I've already tried doing that in Slic3r and that didn't help :( And also it, probably, won't work if I am to move it from menu screen, right?

– Ilya Smirnoff – 2018-04-19T15:30:00.647

did you set 2nd extruder in config.h? maybe it is time to get as I am using that on minte

– profesor79 – 2018-04-19T15:32:09.177

i've downloaded the firmware that you've recommended and it doesn't want to load

– Ilya Smirnoff – 2018-04-20T05:28:25.630

Are you sure you installed the CH340 drivers and use the correct COM port? Does it compile? – 0scar – 2018-04-20T06:51:21.713

@IlyaSmirnoff please see for flashing reference

– profesor79 – 2018-04-20T08:25:56.287

@0scar what are the CH340 drivers? – Ilya Smirnoff – 2018-04-20T16:25:43.877

it is a cheap usb to serial bridge that is in most arduino clones – profesor79 – 2018-04-20T16:26:25.973

@profesor79 none of the solutions worked :( – Ilya Smirnoff – 2018-04-22T17:06:53.573

@profesor79 now i have problems with AVRDUDE

– Ilya Smirnoff – 2018-04-22T17:08:58.753

please check that @IlyaSmirnoff

– profesor79 – 2018-04-22T17:52:20.380

@profesor79 I've already tried everything. well... It's not working – Ilya Smirnoff – 2018-04-23T14:29:43.593