Oversized pieces

4

After a long time tweaking my new 3D printer I solved all the unexpected errors and I can print succesful pieces but I am facing a "problem", they are over sized, I found this problem trying to print a Raspberry Pi Case and an smartphone case, the printed pieces are bigger than the objects.

Here some related information

Printer: Geeetech Prusa i3 Pro B

Firmware: My GitHub (Marlin)

Software: Repetier Host with Slic3r

Does somebody know how could I solve it? Thank you very much

Alberto Méndez

Posted 2018-01-09T13:23:01.660

Reputation: 163

Is this with every print? Or did you hit the scale multiplier by accident? And have you changed/modded your printer? – Granny – 2018-01-09T14:47:31.690

I could sure it is with every print, I tried to print yesterday another fixed size piece (the third one, in different dates) and it is bigger than it should be. I am suspecting about the step per mm option in the firmware. let me mention they aren't too much bigger, just some mm, but enough to don't fit the objects – Alberto Méndez – 2018-01-09T14:50:46.130

If you have changed any poulies or belts your steps per mm could have changed and with this your printer will go further or shorter than its actually supposed to be. – Granny – 2018-01-09T14:52:03.840

I didn't changed them, the oversizing problem is probably there from the beginning but I didn't noticed it until now, when I tried to print fixed size models. This evening I will try to check the step per mm configuration and let you know. Thanks @Granny – Alberto Méndez – 2018-01-09T14:54:18.777

It would be helpful (to say the least!) if you posted the model of your printer and all the info you can find about the firmware & software on the printer as well as the application you're using to do the slicing. – Carl Witthoft – 2018-01-09T15:22:52.827

Hi @CarlWitthoft I didn't do it because I'm away from my printer, I will try to add some info which I can remember now and the rest later. – Alberto Méndez – 2018-01-09T15:30:41.783

2I finally solved it by reducing the steps per mm in the printer firmware. Thank you all – Alberto Méndez – 2018-01-10T07:53:08.387

Answers

3

You have to know:

  • distance between belt teeth (usually 2mm)
  • number of teeth on pulley
  • motor step angle 1.8 deg?
  • microstepping count, probably 16?

Then you can enter all these numbers info the calculator here: https://www.prusaprinters.org/calculator/

Gunslinger

Posted 2018-01-09T13:23:01.660

Reputation: 632

This helps but I had to do some manual adjustment in the step per mm option to solve it. Thank you very much – Alberto Méndez – 2018-01-10T07:52:19.927

1Yes, the result of the calculation should be entered as the steps per unit, and if the information is correct this should be a first-time accurate solution. Experimenting as described in Alberto's answer will work if you don't know the mechanical parameters, but may not be very accurate and will take multiple iterations to get "close enough". – mbmcavoy – 2018-01-11T20:07:26.447

I will try it again because as you say my method can lead to errors, when I have done it I will update all the information. The changes didn't work as expected, some pieces keep giving size problems (usually too small now) – Alberto Méndez – 2018-01-12T14:59:43.473

I changed it to the result from the calculator (80 steps per mm) but the extruder heater stopped working and I couldn't try it deeply. I am waiting for a new one, I will update this when I can do the tests. – Alberto Méndez – 2018-01-16T07:47:47.997

1I finally could try it and thanks to the calculator I could set the right steps per mm, I noticed too that the extrusor steps per mm I had set in the firmware were wrong, I had them in 98 and the default value is 158.8308. After changing these (X, Y and extrusor steps per mm) values the print size is the expected. Thank you – Alberto Méndez – 2018-01-24T07:54:48.697

2

I finally solved it by manually adjusting the steps per unit in the printer firmware.

The process is easy just move the extruder to one position and draw two marks, one at the extruder position and another one 10 cm in the X axis from the extruder position then with Repetier or with the the printer controls move the X axis 100 mm, if the extruder stops after the mark reduce the steps per unit or increase them if the extruder stops before the mark, do until the movement matches both marks. Repeat for the Y axis.

You can see the changes I made to the firmware in my GitHub

Alberto Méndez

Posted 2018-01-09T13:23:01.660

Reputation: 163