Why does my MKS Base not recognize my thermistors?

5

I recently upgraded my Geeetech Acrylic Prusa i3 with a MKS Base V1.4 and it would not recognize the thermistors (100K {type 1}) even though they worked fine with the Arduino Mega 2560 with the RAMPS shield.

After changing the thermistors for the 4th time it began to work, but the model printed was quite distorted. Then without warning it suddenly does not recognize them again. The board does create the USB port, but does not appear to communicate with my computer.

Is the problem more associative with the board or my computer?

BYE

Posted 2016-02-06T13:53:01.323

Reputation: 191

Does the one that stopped getting recognized, still get recognized by the arduino? – Eric Johnson – 2016-02-08T23:15:14.797

What exactly means "{type 1}". And did you alter your firmware? – amra – 2016-02-10T08:22:56.737

@EricJohnson It was both thermistors that stopped being recognized. If there is another way of determining whether the Arduino recognizes them other than through the computer (Repetier Host) I am unaware of it. – BYE – 2016-02-10T12:08:42.450

@amra Arduino configuration.h lists thermistors/thermocouple by type, and there are a large number listed there, my particular thermistor is a 100K type 1 on that list. – BYE – 2016-02-10T12:12:42.847

I see. My assumption was that you have wrong configuration in your firmware. Did you try another SW instead of Repetier Host, e.g. Pronterface? – amra – 2016-02-10T13:28:14.803

@amra yes I did as a matter fact I used two versions of repetier and Pronterface to no avail. What confuses me the most is that it worked for a short time then just quit again. I have reset the board and attempted to reload the Marlin firmware but it will not reload, even though it does set up the USB com port. Thank you for your interest and help. – BYE – 2016-02-10T15:00:30.027

I would verify if your board is working fine. Could you measure voltage on the thermistor? It should be around 5V (it was 4.79V on my RAMPS board). And about the change to Marlin firmware - did you use Arduino IDE for the upload? If yes, then what was the error? – amra – 2016-02-11T09:14:14.697

@amra The voltage across both pins on the board is 4.95 on the 20v dc scale, and the resistance is 102. or above on the 200 volt scale. Yet the thermistor reading on my computer remains at 00.0 for both thermistors., and no other components are functional (motors, endstops). Thanks for the effort. – BYE – 2016-02-11T12:05:20.193

@amra By the way I worked on the Matlin firmware until I got no errors, only a white reading of the upload particulars. – BYE – 2016-02-11T12:09:02.310

Here are good videos about configuring marlin firmware: https://www.youtube.com/watch?v=2RbcMvhatjU and https://www.youtube.com/watch?v=In93vVd1WDQ

– amra – 2016-02-11T15:46:53.017

@BYE Did Marlin firmware help with the thermister? – amra – 2016-02-12T17:33:55.120

@amra no it did not I am pretty sure I received a defective board. thanks for the help and the references. Sorry to be late replying internet router has been down. – BYE – 2016-02-14T22:33:38.323

Answers

2

You should:

  1. Ensure that firmware has proper thermistor configuration. For details see this video tutorial.
  2. Verify that your thermistor works properly. Measure voltage on it. It should be around 5V on this particular board.
  3. There is possibility that the board is defective. Replace it.

Temperature sensor possibilities for Marlin firmware:

// -2 is thermocouple with MAX6675 (only for sensor 0)
// -1 is thermocouple with AD595
// 0 is not used
// 1 is 100k thermistor - best choice for EPCOS 100k (4.7k pullup)
// 2 is 200k thermistor - ATC Semitec 204GT-2 (4.7k pullup)
// 3 is Mendel-parts thermistor (4.7k pullup)
// 4 is 10k thermistor !! do not use it for a hotend. It gives bad resolution at high temp. !!
// 5 is 100K thermistor - ATC Semitec 104GT-2 (Used in ParCan & J-Head) (4.7k pullup)
// 6 is 100k EPCOS - Not as accurate as table 1 (created using a fluke thermocouple) (4.7k pullup)
// 7 is 100k Honeywell thermistor 135-104LAG-J01 (4.7k pullup)
// 71 is 100k Honeywell thermistor 135-104LAF-J01 (4.7k pullup)
// 8 is 100k 0603 SMD Vishay NTCS0603E3104FXT (4.7k pullup)
// 9 is 100k GE Sensing AL03006-58.2K-97-G1 (4.7k pullup)
// 10 is 100k RS thermistor 198-961 (4.7k pullup)
// 11 is 100k beta 3950 1% thermistor (4.7k pullup)
// 12 is 100k 0603 SMD Vishay NTCS0603E3104FXT (4.7k pullup) (calibrated for Makibox hot bed)
// 13 is 100k Hisens 3950  1% up to 300°C for hotend "Simple ONE " & "Hotend "All In ONE"
// 20 is the PT100 circuit found in the Ultimainboard V2.x
// 60 is 100k Maker's Tool Works Kapton Bed Thermistor beta=3950
//
//    1k ohm pullup tables - This is not normal, you would have to have changed out your 4.7k for 1k
//                          (but gives greater accuracy and more stable PID)
// 51 is 100k thermistor - EPCOS (1k pullup)
// 52 is 200k thermistor - ATC Semitec 204GT-2 (1k pullup)
// 55 is 100k thermistor - ATC Semitec 104GT-2 (Used in ParCan & J-Head) (1k pullup)
//
// 1047 is Pt1000 with 4k7 pullup
// 1010 is Pt1000 with 1k pullup (non standard)
// 147 is Pt100 with 4k7 pullup
// 110 is Pt100 with 1k pullup (non standard)

amra

Posted 2016-02-06T13:53:01.323

Reputation: 1 881