Ramps 1.4 and extruder

4

I have ToyRep printer (RepRap), with RAMPS 1.4 on the board. And I am powering in from ATX power supply with 12V. And the problem is it doesn't heat to 230(for ABS), max value was 173 degrees by Celsius. Is it bad extruder or not enough power?

Jerey

Posted 2017-11-02T19:47:54.820

Reputation: 61

I had the same problem in one of my printers, the Arduino Mega was burnt due a bad instalation of limit switch Positive instead of Negative. So the shield was getting hot due abnormal signals. I change the Arduino Mega and everything is working. – Fernando Baltazar – 2017-11-03T06:26:54.487

Answers

2

  1. Make sure that your heating device (resistor) is for 12v, not 24v (resistance is < 10Ohm)
  2. Check if the temperature readings that you get in your system are (at least roughly) the same as actual temperature (thermocouple with multimeter or any other device that can measure ~200C will help)
  3. Check if connections are good enough. Low voltage at hotend is an indication of possible problem. ATX power wires are often too thin to transfer enough current. Consider replacing them with at least 2.5mm2 (AWG 14)

Mikhail Z

Posted 2017-11-02T19:47:54.820

Reputation: 798

Is 3A enough for RAMPS, heatbed and extruder? I am planning to change power supply to one charger 12V and 3A. – Jerey – 2017-11-02T22:15:18.810

3A is not enough, the ATX power supply at least should be rated as 300W – Fernando Baltazar – 2017-11-03T05:35:12.697

You can easily calculate required current by summing up major consumers: motors (max current), main board (Arduino + RAMPS), hot end, heat bed (if any), plus add extra 1-2A to ensure that power supply won't overload. In other words, 6A may work, 3A - no. – Mikhail Z – 2017-11-03T09:02:26.047

@Mikhail Z i have done it, it still doesn't help. Before electricity was 10V now 12V. But it still writes printer killed in pronterface – Jerey – 2017-11-04T21:16:00.500

>

  • Have you tried testing temperature with thermocouple? What is your heating resistor's resistance?
  • < – Mikhail Z – 2017-11-05T17:50:11.897

    @Mikhail Z unfortunately no, I don't have anything to test, multimeter doesn't have this mode – Jerey – 2017-11-05T21:48:57.450

    I'm afraid we are starting to misuse the system. Please read my previous comment. Measure your heater resistance and read #1 in my answer – Mikhail Z – 2017-11-06T09:15:05.997