Nozzle rubs on previous layers



I'm having a frustrating problem on my recent built custom 3d printer so every single print I made, from the third layer, the nozzle is "rubbing" on the already placed filament. This results in a complete mess, melting the previous layers with the nozzle / new extrusions coming, getting malformed and out of precision forms, if I leave this happening, my Y axis motor (bed) start to jump steps (by the force of nozzle friction to cold material). To stop that symptom, on the beginning of this, I have to raise the Z axis by hand turning about 1/8 rotation of T8 fuse. By doing this, every rest of my printing runs peaceful, nicely and beauty.

I'm using Marlin Firmware, most recent version, and Ultimaker Cura. My Nozzle size is 0.5 and i'm using Ultimaker Cura's Fine Preset (0.1mm height)

My stepper motors axis are very well calibrated (X, Y, Z and Extruder). I tried:

  • lowering and raising print bed to get spaced or shrunken first layers to see if something help,
  • tried to change Z home offset on display,
  • tried the M206 command to change print zone of Z axis,
  • tried to change first layer height on Ultimaker Cura,

but nothing seems to solve my problems.

Due to my lack of experience I don't know what I could try to solve this frustrating issue. I already check and rechecked my mechanical structure and everything was fine solid and very well balanced and on square.

enter image description hereenter image description here

From comment:

  • Printing speed are 40 mm/s,
  • Temps:
    • Hotend: 220 °C;
    • Hot Bed: 120 °C;
    • I have also tried 110 °C,
  • My Z-axis uses 800 steps per mm (1/32 micro stepping on DRV8825 at RAMPS).

I'm thinking about over extrusion but I have fine tuned my stepper, checked and rechecked for it and seems normal


Posted 2017-10-03T04:11:02.003

Reputation: 131

1"most recent version" changes: since this question has been asked, Marlin released 1.8, 1.9. 2.0 and possibly more. – Trish – 2018-10-08T10:55:17.790

As @Trish states, saying that it was the most recent version isn't particularly useful. Even looking at the date of your date and correlating that with the release dates of Marlin may not give an accurate estimation as to the version that you were using. Could you edit your question and state the actual version that you were using, if you can remember? Thanks. – Greenonline – 2018-10-10T08:56:37.377

Hi, did you find a solution to your problem? I am currently also facing it... – zwep – 2021-02-14T18:13:17.003

@eduardogarcia234 which material are you using. your above mention profile is for ABS. – Kallz – 2017-10-03T09:18:04.363

1Going by what you think is happening, the Z is skipping steps.... or your over extruding. Bump the stepper current. if that's not it, change back to 1/16 or try other drivers and see. if it's either then those rods aren't 8mm per rev. – Eric Kelly – 2017-10-03T13:06:19.200

Just wondering if you have tried printing something without a curved edge? Just because I have had similar problems when printing shapes that have had a curved edge like you have shown in the picture. – user802599 – 2017-11-02T23:59:03.217



I have made some learning on mechanical setup and discovered some issues on my printer, there are few:

  1. Bed warped, even with glass (thin thickness), making BAL confused with Z-movement over the bed.
  2. Overextrusion making layer oversized in terms of thickness.
  3. Some of missing mechanical fine adjustments.

The main reason for this symptom was the overextrusion (that made my X and Y axis jump some steps when hotend collapses in the already-printed materials on their movements).

I hope this helps some of those who have this similar problem!


Posted 2017-10-03T04:11:02.003

Reputation: 131


I'm not a 3d printing expert by any means, but I had some funky layer stuff going on before "wrinkled" first layer & gross edges w/overlap. For my printer, the problem was I was over-extruding.

I followed this video by Tom's 3D: 3D printing guides - Calibrating your extruder

For some reason, I had to do it twice before it actually worked. Once I got that calibrated (and fixed an uneven print bed), I was good to go.


Posted 2017-10-03T04:11:02.003

Reputation: 106


Your Z axis movement is somehow wrong. You should check steps/mm, z acceleration and speed. Try moving your z 10cm up and use caliper to check if it is correct.

Alec Bellinghausen Pagliarussi

Posted 2017-10-03T04:11:02.003

Reputation: 31


The first picture seems to show layer shift. Usual causes include:

  1. Missed Z movement, so the nozzle hits the build and the layer is offset.
  2. Bad acceleration in X/Y, so there is missed X/Y movement, and the layer is offset.

Adjustment: reduce Z G0 speed, and reduce X/Y speeds (G0 and G1) and acceleration, and then repeat.

Hopefully, correcting this will make the issue in the second picture easier to diagnose.


Posted 2017-10-03T04:11:02.003

Reputation: 2 113

i will try these changes as suggested and also another slicing app, then i'll return with results and photos thank you – eduardogarcia234 – 2017-10-03T19:14:34.567


Does Cura have options for avoiding perimeters during moves? And does it have an option to step up the z axis during non print moves? These were the two issues I was having with the nozzle dragging through the previous layers on my prints. I set the z axis to move up 0.2 mm during non print moves and to avoid Perimeters during non print moves (using Slic3r) which eliminated this issue for me almost entirely.

jeremiah harless

Posted 2017-10-03T04:11:02.003

Reputation: 89


Did you check if your Z stepper became loose over time? Or any other component down the line to move the nozzle in the Z axis.

X Zhang

Posted 2017-10-03T04:11:02.003

Reputation: 1