Issues with OctoPi connecting to FlashForge Creator Pro via Serial Communication

5

I've recently initialized OctoPi onto my Raspberry Pi, proceeded to connect it to my local internet, and then connected it to my FlashForge Creator Pro (2014 edition)

Everything seemed to be going smoothly until I tried to connect to the printer; the Pi didn't seem to be able to pick up a usable Baudrate (after being trying out all of the usable ones).

For example, when trying out 9600, I would get:

Trying baudrate: 9600

Send: N0 M110 N0*125

Recv: ��r># ���& �

What should I do to fix the problem?


Note that I got the same types of messages back (with garbled 'special' characters) when trying using the "auto connect" feature.

Dimitry M

Posted 2017-02-14T23:37:12.470

Reputation: 91

Answers

1

I got the same problem.
Auto-detect baud rate was not working too.
So I manually tried every baud-rate and finally found one working, for me it was 115200.
Good luck!

Captainju

Posted 2017-02-14T23:37:12.470

Reputation: 21

0

Install GPX via command line. To do this, type

/home/pi/oprint/bin/pip install "https://markwal.github.io/octoprint-download/OctoPrint-GPX.tgz" then go ahead and restart octoprint and try connecting again.

Brandon Fitzgerald

Posted 2017-02-14T23:37:12.470

Reputation: 1