I can not really connect successfully to my printer via USB

2

I have a Tronxy P802M (very similar to the Anet A8, but using a Melzi2.0V5 board) that seems to work fine (I just finished building, and axes movement and the integrated display work) but when I try to connect to the printer from my Simplify3D on Windows 10, I get the following:

[...]
  Connected to machine!
SENT: T0
READ: ok 0
READ: wait
SENT: M105
READ: ok 0
READ: T:24.44 /0 B:23.33 /0 B@:0 @:0
  Connection failed.

My other printers all connect fine.

brandstaetter

Posted 2017-01-26T10:30:00.143

Reputation: 131

Try doing this in Simplify3d and see if it works - Go to Tools --> Firmware Configuration and then click the Communication tab. Set the flow control to "Hardware flow control". – tjb1 – 2017-01-26T15:10:20.297

Nope, did not change much, except now the initial connect does not work. I also tried a different USB cable and using a direct USB port as well as suing a USB2 hub... – brandstaetter – 2017-01-27T08:46:59.633

Operating system? – Sean Houlihane – 2017-01-27T10:28:09.793

Windows 10 - sorry, forgot the details – brandstaetter – 2017-01-27T14:30:36.003

1Okay have you set the Baud rate? I know thats an issue with slic3r. Can you see the printer under devices? – StarWind0 – 2017-01-27T17:22:51.083

1Yes, Baud rate is set the same on both sides (otherwise there are different errors). The COM port shows up under devices. – brandstaetter – 2017-01-28T20:42:04.650

2This is more suited as a comment. Moreover, the fact that he's receiving something legible (like the "T:24.44" line), means the baud rate must be correct. – Tom van der Zanden – 2017-01-29T08:49:56.043

Answers

1

The Simplify3D support site mentions to disable the "wait for startup command" option in the firmware configuration for S3D.

This allows me to make a rudimentary connection to control the printer, however e.g. during the bed levelling wizard of S3D, the connection still breaks off.

It works reliably with Octoprint. I'll consider that good enough.

brandstaetter

Posted 2017-01-26T10:30:00.143

Reputation: 131

1

If you are using a USB 3 port to connect the printer to your PC, try connecting via a USB 2 hub.

My Vector 3 will not work on a USB 3 port, only on a USB 2 or lower. The device correctly mounts and presents but serial communication fails. One of my laptops only has USB 3 ports on it, so to work around the limitation I connect via a cheap USB 2 hub.

I have heard that many 3D printers use a similar USB to UART / serial connector chip and that they suffer from similar limitations as a result.

TafT

Posted 2017-01-26T10:30:00.143

Reputation: 121

already tried that, did not change anything :( – brandstaetter – 2017-02-01T15:23:25.077

The cheapest, and common, USB to Serial IC (i.e. an FTDI clone) in use, seems to be the CH340g – Greenonline – 2017-02-01T16:18:11.260

1@Greenonline The CH340 is not an FTDI clone. Not every USB to Serial IC needs to be an FTDI clone. The CH340 happens to be an independent design. – Tom van der Zanden – 2017-03-12T13:00:40.960

@TomvanderZanden - OK, understood. :-) I guess I should have said substitute rather than clone. – Greenonline – 2017-03-12T13:05:56.347

-1

Try changing your port in the control menu. By default, mine is set to COM 1 and I have to change it to COM 3.

3d noob

Posted 2017-01-26T10:30:00.143

Reputation: 1

I get a response from the printer: READ: T:24.44 /0 B:23.33 /0 B@:0 @:0. It just aborts the connection due to some timeouts. Looks like S3D is very strict when it comes to bad connections or slow boards – brandstaetter – 2017-05-05T12:07:06.170