Z-axis steppers and bed alignment problems

8

I've actually solved this, but I think its still a useful question which I don't think is easy to answer with existing questions.

As soon as I'd built my ANET-A8 (Prusa i3 DIY kit), I found I was having problems with the extruder crashing into the bed. Although I thought I'd adjusted the bed leveling OK, the calibration seemed to keep getting messed up.

I tracked this down to two factors. First, I was winding the extruder head up some distance before loading the filament and starting a print. Second, at roughly half-way up the axis, the right-hand thread seemed to be getting stuck (more often when moving up than down).

What wasn't clear (and not mentioned in the building instructions) was what might cause this problem.

Sean Houlihane

Posted 2016-11-21T10:47:13.383

Reputation: 3 622

Is it correct to use the prusa tag for clones? – Sean Houlihane – 2016-11-21T10:47:35.140

(thanx for creating it) – darth pixel – 2016-11-21T11:00:37.773

@SeanHoulihane There's no such thing as a "clone". The Prusa design is open-source and in my opinion, "Prusa" refers to any number of designs. – Tom van der Zanden – 2016-11-21T12:54:18.340

@TomvanderZanden Thanks for clarifying - I edited the tag :) – Sean Houlihane – 2016-11-21T13:10:35.267

In many open source projects the name is trademark, while the designs are copyleft, the company still wants to maintain their brand (and reputation). However, I don't know Prusa's feelings on it. – HaMMeReD – 2017-05-11T19:16:58.450

Answers

3

So after reading the instructions more carefully, ANET do cover this in their operating instructions under troubleshooting. On closer inspection, I realised that the brass nut following the right hand thread seemed to be out of alignment with the stepper at the bottom. Fiddling with the flexible coupling helped a bit, but what I needed to do was place the assembly at the tight point, slacken the 3 bolts marked SHCS in the diagram, then tighten them again. I was expecting I might need to open out the holes, or re-make the white (factory printed) part, but this wasn't necessary.

From ANET manual

Sean Houlihane

Posted 2016-11-21T10:47:13.383

Reputation: 3 622

1Found it in the A8 Operation instruction-1.1.pdf file provided on the SD card, page 66 – Charly Koza – 2019-01-20T12:50:56.333

1ha! so there is caret nut :) it's good to hear you've solved it (btw: my suspicion about 1. assembling according to instruction was priviledged) ;) and 2. that there is a problem was priviledged too) – darth pixel – 2016-11-21T11:42:55.380

1I don't think caret nut is a real word. It is probably a mistranslation. – Tom van der Zanden – 2016-11-21T12:53:28.793

1@darthpixel - I would wager that caret actually means carriage, as in the x-axis carriage. Mostly because of the phrase in Tom's answer, which can eventually hang caret, which probably should be which can eventually hang [the x-axis] carriage – Greenonline – 2016-11-21T16:57:35.007

where did you find this under troubleshooting, I think Im having the same issue. Can't find what you are refereing to. – user6668 – 2017-04-04T21:38:45.710

6

I assume you did everything according to the instructions but here is a checklist of what could be possibly wrong:

  1. Friction - check if you can rotate/move parts without lot of resistance
  2. Screws - check if screws on couplings are tight and they don't slide over a shaft or thread
  3. Stepsticks - check if they are cooled properly and similar (as there are two of them)
  4. Carriage nuts on threads - check if they do not slide out of their nests while [the x-axis] carriage goes up
  5. Filament - check if filament unrolls without resistance which can eventually cause [the x-axis] carriage to hang.

IMO #2 and #3 are the most possible cause

Diagram of issues 1, 2 and 5

darth pixel

Posted 2016-11-21T10:47:13.383

Reputation: 3 363

caret nut is a new term for me. – Sean Houlihane – 2016-11-21T11:01:55.130

well - here is top left elem (prusa i2) where such nut sits http://3dprinter.my/cart/images/Reprap%20Prusa%20i2%20Printed%20Parts%20Black.jpg more or less the same is in prusa i3

– darth pixel – 2016-11-21T11:11:50.687

I don't think caret nut is a real word. It is probably a mistranslation. – Tom van der Zanden – 2016-11-21T12:53:16.160

With (2), I had the spindle and the thread pressed tight together, the coupling was unable to bend... – Sean Houlihane – 2016-11-21T15:46:32.347

1@TomvanderZanden - I think caret should actually be carriage – Greenonline – 2016-11-21T16:58:33.677

@SeanHoulihane the issue is to have screws properly screwed – darth pixel – 2016-11-21T17:10:54.413

@darthpixel - Would you happen to have a source for the image and the checklist? Just to check the intended meaning of caret. I have downloaded the Anet troubleshooting guide but it was not mentioned in that document.

– Greenonline – 2016-11-21T20:21:52.947

@greenonline checklist and image source, both come from my head :) let's forget this caret thing, I've just changed it in my ans – darth pixel – 2016-11-22T00:21:43.683

0

From http://3daddict.com/anet-3d-printer-common-mistakes-fix/

The motor shaft and the threading rod must have space between them in the flexible coupler.

That means unlocking the coupler from the motor shaft and moving it up a bit, in the end the threaded rod nearly touches the printer top hole instead of having like a 1cm gap. This will allow the coupler to flex, and thus should handle small misalignments of the brass nut.

That's about point 2 of @darth-pixel answer, but before locking the screws, make sure to have empty space between rod and motor shaft

Charly Koza

Posted 2016-11-21T10:47:13.383

Reputation: 101