Installing Slic3r on Kubuntu 14.04 with NVIDIA

1

I am running crazy trying to install Slic3r on my Kubuntu 14.04. It is a fresh Kubuntu and I downloaded the Slic3r package from them.

At first it worked well but then I changed the display driver to NVIDIA instead of the default Nouveau. I have repeated this operation a couple of times and I am almost sure that the NVIDIA driver screws up my system.

I have read and followed several "SOLVED" posts but none of them gave me a solution.

Any ideas?

Luis Rosety

Posted 2016-11-12T22:55:29.563

Reputation: 143

Is this really a suitable question for this site? It's only marginally 3D printing related, and might be more suitable for a place where they deal with troubleshooting Ubuntu drivers. – Tom van der Zanden – 2016-11-13T09:16:12.070

1I am having this problem only with this application, which is mostly used in the 3D Printing world. This is the reason why I ask here this question. There may be some other member having faced the same problem with this application. – Luis Rosety – 2016-11-13T14:44:49.090

Does the command line functionality of Slic3r work? – Eric Johnson – 2017-01-04T03:04:12.580

I have upgraded to Kubuntu 16.04 and it works after git cloning it. – Luis Rosety – 2017-01-05T20:35:45.317

Answers

1

There is a huge problem with any linux distributions and Nvidia drivers. I have tried countless times to get that driver to work but it crashed my systems time after time. If your slicer works with the default driver i would not try to change it. If it doesn't then you may have to go to windows where the driver is guaranteed to work. I know this is not the answer you are looking for but unless you can code a new driver to work for Linux thats the only solution.

John Perry

Posted 2016-11-12T22:55:29.563

Reputation: 11

Yes John! Unfortunately I got the same conclusion after so many trial and error tests. Surprisingly Cura seems to work so far and I'm sticking to it. – Luis Rosety – 2017-04-18T21:15:38.800