Z banding issue

2

I'm currently facing a Z banding issue that frustrates me more and more.

My printer is a modified Anycubic I3 Mega.

Customizations:

  • Mainboard: Bigtreetech SKR 1.4 Turbo
  • Stepper Drivers: TMC 2208 v3
  • Hotend: E3D Titan Aero
  • Hotbed: 5 mm aluminum base plate with a 200 W 12 V silicon heat mat and 3 mm hard paper as print base
  • External MOSFETs for the hotbed and hotend each
  • Bigtreetech 3.5 inch TFT screen as display
  • BL Touch sensor
  • Marlin version 2.0.6.1

What I tried to fix this issue:

  • check leadscrews for debris
  • cleaned leadscrews and applied new grease
  • checked Z couplers and hand tightened all screws
  • checked tightness of the Y/X axis belts
  • increased the driver current
  • replaced the 12 V 25 A PSU with a 12 V 30 A PSU
  • Extruder steps re-calibration
  • PID auto tune for hotend and bed

Pictures of the XYZ calibration cubes I printed:

enter image description here

enter image description here

Used slicer parameters (Prusa Slicer):

  • material: PETG
  • 240 °C / 100 °C hotend/bed
  • Infill 30 % with 60 mm/s
  • outer perimeter with 30 mm/s
  • 100 mm/s travel speed
  • 1 mm retraction with 40 mm/s retraction speed

The number of these horizontal lines and their occurrence is different on each print.

Any ideas?

Christian

Posted 2021-02-16T13:09:02.410

Reputation: 21

Hi welcome to 3DPrinting.SE. It looks like your Z crew sometimes misses some steps. Did you measure the height of the calibration cubes. – 0scar – 2021-02-16T13:46:14.797

@0scar My calipers are not that exact but yes, it looks like its a litte bit too small. On my latest print I have 4 of those rings and it measures 19.4mm. During print it looks a lot like the z is not moving up for one layer resulting in printing the next layer on the same hight resulting in squishing the old layer which creates these rings. – Christian – 2021-02-16T13:55:39.903

@0scar so what could possibly cause these missing steps? – Christian – 2021-02-16T14:53:41.560

Are you sure the stepper drivers for the Z are correctly configured, enough current? – 0scar – 2021-02-16T14:59:15.233

Yes I am. The current ist set to X 860mA Y 860mA Z1 950mA Z2 950mA E 850mA. M122 shows no errors or anything suspicious. – Christian – 2021-02-16T19:03:29.377

2Hi, it is great that you solved your issue, but please put your solution in an answer and then mark the answer as the accepted solution. Firstly, this will remove your question from the unanswered queue and secondly, putting the answer in the question breaks the Q&A mechanism of the site. Thanks. – Greenonline – 2021-02-17T21:18:27.290

Answers

1

So it looks like I finally resolved that issue. I compiled a complete new firmware based on the Marlin bugfix branch. Before I was working on the sources provided in the Bigtreetech GitHub. I started from scratch and put all the settings I needed into the Configuration.h and Configuration_adv.h. Now all rings are gone. Either there was really a bug or something or I messed up something in the firmware I used before and beginning from scratch solved it.

Christian

Posted 2021-02-16T13:09:02.410

Reputation: 11

Since I cannot login into my other account I cannot mark this aswer as accepted solution. – Christian – 2021-02-18T14:50:32.047

1

Hi Christian, many thanks for returning and posting an answer! Please note question "How can one link / merge / combine / associate two accounts / users? (Anonymous / unregistered / cookie, or Google / Facebook / registered)" which directs to "I accidentally created two accounts; how do I merge them?" so you can fix this!

– 0scar – 2021-02-18T15:01:14.407

Ah that's a shame, what happened to your previous login? As 0scar states, the accounts can be merged by the moderators, but it would be easier if you could just use your old account. Oh and thanks for updating the question with an answer, nice one, thanks :-) – Greenonline – 2021-02-18T15:03:49.290