Ender 5 hotend and bed cooling down while auto bed leveling

3

I have an Ender 5 with an auto bed leveling sensor (TRU-LEV 600).

It is working fine, however, as the sensor probes the bed, the nozzle and the bed cool down and are not staying heated as it is getting the points, even though they were heated up in the first place.

How do I stop the bed and hotend from cooling down while the bed is being probed?

Here is my start G-code:

M75; Start Print Timer and Engage Fil Sensor if USB Printing
G92 E0; Reset Extruder distance to 0
G1 E-2; Retracts filament to prevent blobs during probing
M84 E; Disable E Motor for probe accuracy on direct drive systems
G28; home all axes
G28 Z; home Z to get more accurate Z position
G29; TRULEV mesh generation
G4 S10; wait for heaters to recover
M117 Purge extruder
G92 E0; reset extruder
G1 X0.1 Y20 Z0.3 F5000.0; move to start-line position
G1 Z1.0 F3000; move z up little
G1 X0.1 Y100.0 Z0.3 F750.0 E15; draw 1st line
G1 X0.4 Y100.0 Z0.3 F5000.0; move to side a little
G1 X0.4 Y20 Z0.3 F750.0 E30; draw 2nd line
G92 E0; reset extruder
G1 Z1.0 F3000; move z up little
M117 Printing.....

isaac7437

Posted 2021-01-26T15:09:15.483

Reputation: 31

Only during probing, or does it completely stop heating? – 0scar – 2021-01-27T06:14:45.823

@isaac7437 did my answer help you? If the question was resolved, please accept the answer. If not let's dig deeper... – octopus8 – 2021-02-02T03:56:54.357

Answers

1

For Marlin firmware, you should check the setting PROBING_HEATERS_OFF in Configuration.h file:

//#define PROBING_HEATERS_OFF       // Turn heaters off when probing
#if ENABLED(PROBING_HEATERS_OFF)
  //#define WAIT_FOR_BED_HEATER     // Wait for bed to heat back up between probes (to improve accuracy)
#endif
//#define PROBING_FANS_OFF          // Turn fans off when probing
//#define PROBING_STEPPERS_OFF      // Turn steppers off (unless needed to hold position) when probing
//#define DELAY_BEFORE_PROBING 200  // (ms) To prevent vibrations from triggering piezo sensors

It is probably enabled in your case. You may want to switch this off and reinstall firmware to maintain constant heating during probing.

However, you may want to take into account possibility of electrical or magnetic intereferences during probing from heaters and their circuits. Disabling them for a while may eliminate these influences and give more reliable measurements. Unless the bed ot hotend are unable to maintain stable temperature for a while and cool down too much (e.g. bed changing shape). So may want to experiment what works the best in your case, maybe including other settings listed in given section.

octopus8

Posted 2021-01-26T15:09:15.483

Reputation: 722