Eryone Thinker SE Ignoring Stopswitch & Gantry Only Moves Down

0

I just got a Eryone Thinker SE and went through a lot of trouble to get it even working.

My first major problem was it would keep trying to ignore the zstop switch and go lower than it should be. I managed to fix it by doing a firmware update to it, and after a lot of trouble with getting the right temperature I started printing a test cube. I left it to print checking up on it every 30 minutes or so and near the finishing of the cube I came back to a screen saying something like "power failure, resume print", so of course I choose resume print but what it ended up doing was moving down, piercing the block on the print bed and then dragging it with it as it decided to home itself. So I immediately hit the reset button do it didn't try to push the block into the print bed.

But now when I auto home the printer, it jabs the print nozzle into the print bed, and it ignores the z-axis stop switch causing the right side of the gantry to go lower (due to there being no stopper on the right) . Auto leveling just makes the gantry go down even further on the right still ignoring the stop switch. The other thing is when trying to manually move the z axis, instead of going up (even though the LCD shows a positive number) it tries to go down.

Steps I attempted to do to fix it:

  1. I attempted to do another firmware updates, but to no avail this time.
  2. I checked all the connections and re-seated them.
  3. Scout the internet hoping someone with the same printer or board has had the same problem, to no avail again.

I should note when homing the printer, the normal action for it is to home X then Y, then Z. When homing Z however, NORMALLY, it will hit the switch move up and baby step itself to hit the switch and stop immediately when it touches it. But now, it will hit the switch, then just go down even more.

Video of what is happening here (Google Drive)

The control board on the printer is a Eryone 2560

McGlowSticks

Posted 2020-12-27T16:00:35.743

Reputation: 1

A test cube should take a few minutes, it doesn't require multiple intervals of 30 minutes to be checked... :-) how big is the cube? – 0scar – 2020-12-27T19:46:08.457

Answers

0

You do a critical error in your order of operations: you home. Then you home again.

However, the firmware does not check if the switch is already depressed, it waits for a signal to cut out. But the signal is already not there. And as you will notice, it moves into X+ and Y+ before rehoming into 0, but does not do so in Z.

To prevent that behavior, you need to move the printer up a little till the switch no longer is engaged, then it will properly home the position.

The proper fix would be to alter the home-Z behavior to include a movement upwards by 2 mm before starting the actual homing. This does require a knowledge of Marlin though.

Trish

Posted 2020-12-27T16:00:35.743

Reputation: 15 633

Ah okay. I get that part with the switch and not checking if it is already depressed. The normal action of the printer when homing is to home X and Y, and then it goes to home Z. Before, it would hit the switch then move up to un-depress the switch, then move down just until it depresses the switch again. But now, it hits the switch and just moves down further instead of going back up to hit the switch a second time. – McGlowSticks – 2020-12-27T17:29:40.500

@McGlowSticks that's how the firmware defined the "homeZ" button - I guess that's a pre-modified and not a self-set-up Marlin distribution? – Trish – 2020-12-27T18:54:54.773