Thermal Runaway E1

1

I am currently building a Hypercube Evolution from a kit that was passed on to me. It uses a BIQU KFB2.0 control board and a 24 volt power supply. I have no prior experience in 3D printing.

I was getting to the end of the build. Everything was working. I was testing every component as I added it using Pronterface. I have not covered the aluminium heated bed with anything as I did not want to cause problems for the induction sensor (used as Z Min endstop). The induction sensor has a 4 mm range for ferrous metal and less for aluminium. I was intending to print on blue tape.

One website I visited suggested using feeler gauges as a better choice when levelling the bed. So I did. What I did not know is that both the hotend and the bed have power running to the outer surface. I found out when a feeler gauge touched the bed and the hotend at the same time. Since then, my LCD display gives the message "Thermal Runaway E1 press reset". I have pressed reset on the control board to no avail. Short press, long (5 and 10 seconds) and double press. None of which work. I have disconnected the hotend and it's thermistor from the control board. I have tried using another thermistor, but to no avail. Pronterface, when trying to connect, gives the following two lines:

"Error: Thermal Runaway, system stopped! Heater_ID: 0 Error: Printer halted, kill() called!"

I have disconnected all wires from the control board other than those leading to the LCD screen. The only power coming from the PSU. Still have the Thermal Runaway E1 error.

I have also re-compiled Marlin 2.0.6.1 using Auto Build Marlin and uploaded to the board, still the error persists. Anybody any idea how to fix this problem?

Ramblin' Sid Rumpo

Posted 2020-10-12T21:23:57.327

Reputation: 123

Can you disconnect the thermistor connector at the control board and measure its resistance at that connector with a multimeter? That will check if there is a broken connection somewhere in that part of the wiring. – Andrew Morton – 2020-10-13T19:52:36.640

You wrote "I found out when a feeler gauge touched the bed and the hotend at the same time." - what happened? – Andrew Morton – 2020-10-13T19:53:04.283

When the feeler gauge touched the hot end and the bed at the same time, I got a few pretty yellow sparks. This is when my problems started. The thermistor for the bed shows 137 kilo-ohms. The thermistor for the hotend showed 105 ohms. I removed the thermistor from the hotend and it now shows 110 kilo-ohms. – Ramblin' Sid Rumpo – 2020-10-14T01:29:09.340

My limited knowledge suggests that there may be a short at the hotend. Would i be correct?

I have now removed all connections from the board, other than the stepper drivers and the LCD screen. When I connect to the computer, I still get the Thermal Runaway error on the screen.The powers supply was not connected. Pronterface will not connect. However, I can still upload firmware to the board.

Have I fried my board and if so, will I need to replace the stepper drivers as well as the board? – Ramblin' Sid Rumpo – 2020-10-14T01:42:10.380

Sounds like your hot end thermistor is shorted / damaged. Probably an issue with its insulation.

Try plugging the heated bed thermistor in the hot end thermistor port - does it read correctly then? – towe – 2020-10-14T08:50:53.967

Sorry towe, I have now disconnected everything from the board other than the stepper motors and the LCD Screen. The board will not connect to Pronterface and the LCD screen just reads, Thermal Runaway Error: E1, Printer Halted, Reset. So, at the moment, I cannot check. I can upload firmware to the board, so we do have communication. I have taken a closer look at the thermistor head. On one side there is about 5mm of bare wire between the head and the insulation. – Ramblin' Sid Rumpo – 2020-10-15T01:00:49.730

1Sounds like the sparks indicated a temporary short that damaged something in your circuitry used for detecting thermal runaway. That's the place to troubleshoot. – Perry Webb – 2020-10-16T13:36:23.453

Answers

1

I found the solution. Controller board was broken, I had to order a new one.

Ramblin' Sid Rumpo

Posted 2020-10-12T21:23:57.327

Reputation: 123

1Thanks for posting your own solution! Please accept this answer (possible after 48 hours)! – 0scar – 2020-11-01T10:33:44.140