Stepper driver Vref not the same after switching motherboards

0

A strange problem came up today when I switched my MKS Gen L for a BTT SKR v1.4 Turbo. For my stepper motors (1.7 A) in combination with my LV8729 stepper drivers (R100) I need a Vref of about 0.68 V (where the max Vref for this stepper is around 0.75 V), so I had set the adjustment screw in the correct position for this (did this a few weeks ago on the MKS Gen L board).

However, after simply switching the stepper drivers onto the new (SKR v1.4) board the value of Vref is now suddenly 0.48 V. I tried to turn the screw to increase the voltage but as it already was almost at its maximum I can't increase the voltage any further than 0.55 V which is too low for my motors. Does anyone know what the problem could be here and how to fix this?

Note that I ordered 2 BTT SKR v1.4 Turbo boards and the same occurred on both of them, and I also tried this with 5 different LV8729 stepper drivers without any change in result.

UPDATE: So I just tried my DRV8825 stepper drivers and these seem to be working just fine, so it has to be something with the compatibility with the LV8729 drivers as I just checked them on my Gen L board and they're still working fine on that one...

Mikelo

Posted 2020-07-22T18:46:18.110

Reputation: 53

Is it possible that this an issue in software actually? I've measured the Vref and found that the firmware setting precedes the potentiometer screw, if I remember correctly. Maybe check the firmware settings. – mike – 2020-07-25T19:09:03.627

No answers