Anycubic i3 Mega y axis off



On my Anycubic i3 Mega the y axis control doesn't work properly. If I instruct the printer to move everything to the home position, the bed moves along the y axis until it gets to the end and then gets stuck there, i.e. I cannot move the bed anymore unless I turn the printer off and on again. If I try a print without homing first, it prints fine but the print is slanted in the -y direction.

What I've tried:

  • Replaced the y stepper motor.
  • Replaced the stepper motor drivers.
  • Replaced the motherboard.
  • Inverted the y axis such that the end stop is triggered when homing.
  • Marlin 2.x and 1.x firmware versions from

With the 1.x firmware, there's a grinding noise whenever the y axis hits either end and gets stuck there. No grinding with the 2.x firmware. x and z axes work fine, extruding filament works fine.

I was running the custom Marlin 1.x firmware with stock hardware, which was working fine. Then suddenly I started to get this grinding noise when homing the y axis and have tried all the things above to fix this.

Lars Kotthoff

Posted 2020-04-19T00:24:34.340

Reputation: 101

No answers