Thermal runaway triggers when raising temperature amid cooldown

1

I've noticed an interesting behavior on my Ender 3 with SKR Mini E3 mainboard and Marlin 2.0.x bugfix firmware. (otherwise, all other hardware is entirely stock) After the hotend/bed are commanded to cool down, e.g. after a print completes, I have to wait until after they both cool down to ambient before commanding another temperature setpoint.

If I don't do this, the printer most often triggers thermal runaway protection. (usually citing the extruder, but also sometimes the bed) I think this might be due to the thermal inertia in the material between the heater and thermistors, causing a 5-10 second delay in sensed temperature rise. I don't see any reason why thermal runaway should trigger; the Octoprint temperature graph looks completely normal, with no perceptible anomalies.

Is there some way to tune parameters for thermal runaway protection to alleviate this false-positive situation?

ifconfig

Posted 2020-04-06T05:40:58.337

Reputation: 761

Answers

1

Yes there are ways to tune false positives. For Marlin firmware you can find these option in the Configuration_adv.h file.

From the file itself you can read what you need to do:

 * If you get false positives for "Thermal Runaway", increase
 * THERMAL_PROTECTION_HYSTERESIS and/or THERMAL_PROTECTION_PERIOD
 */

0scar

Posted 2020-04-06T05:40:58.337

Reputation: 25 570

Any recommendations for how to go about increasing both settings? One before the other, increased symmetrically? – ifconfig – 2020-04-06T21:15:58.677

To be honest, I don't know the underlying problem of this, just try to experiment with one at a time. – 0scar – 2020-04-06T21:38:35.453