G29 Bed Level not doing anything on Marlin 2.0

1

I've just updated my Anet A8 with the blue bed level sensor to Marlin 2.0 . Both pressing the Level Bed button on the display or using G29 after G28 in the G-code don't do anything.

G28 Homing works fine, but doesn't put the nozzle at the center like it did on Marlin 1.1.x, instead it puts the sensor at the center of the build plate. G29 worked fine in my previous Marlin 1.1 config.

These are my config files:

Nicola Guerrera

Posted 2020-04-02T06:45:25.030

Reputation: 13

Do you mean the ROKO SN04-N? – 0scar – 2020-04-02T09:47:43.153

Please read this answer (scroll to the bottom for an example for a back-right mounted sensor), your Configuration_adv.h file is incorrect (more specific, the probe area definition is incorrect). In version 2.x you do not define the bed size (absolute) for the sensor, you only specify the offsets (so relative) from the edge! You should be able to figure out what these values need to be using the example.

– 0scar – 2020-04-02T10:16:54.067

Answers

0

From the linked Configuration.h file the probe X, Y, Z probe offset is set by constant array:

#define NOZZLE_TO_PROBE_OFFSET { 75, -35 , 0 }

So, the sensor is mounted at the right-front (X+, Y- according to the Marlin configuration definition) when facing the printer.

This implies that the sensor is limited on the right and at the front.

The probing area used to be defined in Marlin 1.1.x in the Configuration.h file. However, Marlin 2.x requires edge offsets rather than absolute bed size constraints. From the Configuration_adv.h of linked file, the following probing limits are set:

#if PROBE_SELECTED && !IS_KINEMATIC
  #define MIN_PROBE_EDGE_LEFT (75 + MIN_PROBE_EDGE)
  #define MIN_PROBE_EDGE_RIGHT (X_BED_SIZE  - MIN_PROBE_EDGE)
  #define MIN_PROBE_EDGE_FRONT (MIN_PROBE_EDGE)
  #define MIN_PROBE_EDGE_BACK (Y_BED_SIZE -35 - MIN_PROBE_EDGE)
#endif

This is incorrect, this is what you would do in Marlin 1.1.x. Note that this answer describes in detail how to set the bed probing limits. You need to specify the offset from the edge on each side, in schematics the probing area is defined as:

Front-right probe position

From your printer configuration, the probing limits should be set to:

#if PROBE_SELECTED && !IS_KINEMATIC
  #define MIN_PROBE_EDGE_LEFT (75 + MIN_PROBE_EDGE)
  #define MIN_PROBE_EDGE_RIGHT (MIN_PROBE_EDGE)
  #define MIN_PROBE_EDGE_FRONT (MIN_PROBE_EDGE)
  #define MIN_PROBE_EDGE_BACK (35 + MIN_PROBE_EDGE) ; Note that 35 is absolute(-35)!
#endif

0scar

Posted 2020-04-02T06:45:25.030

Reputation: 25 570