Slow speed of the delta 3D printer

2

I'm running a large delta 3D printer with Repetier firmware.

The problem that is irritating me is that the speed of the carriages are too slow, like an old lady that is walking in a football field. When I command G1 Z10, for example, the carriages move with a super low speed. I checked everything but I couldn't find the problem.

Here are the specifics and the current settting of the printer:

  • electronics : Arduino Due + RADDS 3 42cmo6 6 kg
  • 2.5 A stepper motors for x,y and z axes
  • 3 TOSHIBA ''TB67S109'' stepper drivers (0.1 resistance, 1/16 mic stepping)
  • Vref of drivers: 0.7 V (when I increase this to 1 volt a weird sound comes from steppers and the carriages won't move)
  • number of pulley teeth: 20
  • belt pitch: 2
  • steps per rev: 200
  • micro stepping: 1/16
  • steps per mm: 80
  • Max. travel speed: 300 for X,Y,Z
  • Homing speed: 100 for X,Y,Z
  • Travel acceleration: 3000 for X,Y,Z
  • Print acceleration: 1000 for X,Y,Z

PS: I'm currently calibrating the printer and haven't printed anything yet.

Mj996

Posted 2020-03-13T17:37:16.377

Reputation: 21

did you write the firmware custom? have you tried to send the command G1 Z10 F300? – Trish – 2020-03-13T20:03:47.853

Thanks for your reply.Yes I tried that but nothing changed. – Mj996 – 2020-03-14T09:22:10.617

ok, try altering max Travel to the insane 10000, then try with G1 Z100 F1000? – Trish – 2020-03-14T10:57:14.100

1Thanks Terish.I solved it.But now there's another problem the Z stepper motor only moves in one direction. I checked all of the endstops.They work fine. I checked the stepper drivers ,all of them had the same voltage 0.7 v . When I home the printer all the carriages move upward but when they hit the endstops the Z endstop stays triggered I mean the carriage holds the lever of microswitch. – Mj996 – 2020-03-14T13:59:57.083

oh? Did you forget to M503 seed the limits? Write your own answer! – Trish – 2020-03-14T14:00:46.780

I think so.Each time that I uploaded a firmware with new settings the printer remained with old settings.So I had to clean EEPROM first before uploading new settings. – Mj996 – 2020-03-14T14:06:01.187

and another thing that seems weird is that when I swap the X-axis and Z-axis motor cables on the Radds board. Both motors are working just fine but whichever motor that is plugged into the Z-axis motor driver socket would only move in one direction . – Mj996 – 2020-03-14T14:10:38.160

Please check your endstops with M119, usually (from experience), when a stepper only moves in one direction, this is caused by a triggered endstop. – 0scar – 2020-03-15T07:57:54.850

Answers

0

When you command a move such as G1 Z10, you are omitting the speed at which the tool head travels. Without specifying the speed, the speed from the last command or speed setting is used. Frequently, after levelling the bed, the tool head is raised in Z direction with a low speed (movement in Z direction is always much slower than in X or Y direction), if you command a movement after raising the tool head it uses this speed. For faster movement you must include the feedrate, e.g. G1 Z10 F600, now it will accelerate from the initial feedrate (e.g. 300) to 600 during the move. If you want instant speed you set the feedrate first and then move the tool head:

G1 F600
G1 Z10

0scar

Posted 2020-03-13T17:37:16.377

Reputation: 25 570

Remember, this is a Delta, the XYZ-"axis"-Motors are all moving along the vertical and their relative position causes the printhead to move in the XY plane as well as the Z axis. – Trish – 2020-03-15T10:41:19.997

1@Trish I know, the fact that this is a delta machine has nothing to do with it, this is generic theory about G-code. But good you mention this for others to understand. :-) – 0scar – 2020-03-15T17:59:00.680