Extruder motor making a knocking sound, nozzle is not clogged

1

I've been trying to print anything for the past few days. Every time I go to print something the printer stops pushing plastic out and usually the motor makes a knocking sound.

My original thought was that my E-steps were off (because they were) but I solved that and I still have a problem. Then I noticed that I was struggling with getting the PLA filament to feed into the nozzle. I assumed it was a clogged nozzle and possibly heat creep (because I was a dummy and used my old, bowden retraction settings on my new, direct extruder). I cleared out the clog and I'm able to feed plastic through after disengaging the idler arm. Though, I do struggle getting the filament into the nozzle. Maybe it's due to the Hemera's tight tolerances or due to a misalignment in the hot end, I'm not sure yet. Once I do get the plastic in, it quickly and easily pushes through and spits out of the nozzle so I think that my nozzle isn't clogged. I did do a cold pull the other day.

But I've noticed that my extruder is making a knocking sound, as if someone was gently rapping on my chamber door. I also see that the gears move one step back and forth. It looks to me that the motor is stuck or frozen. I'm pretty sure that it's not skipping steps. The sound happens at varying heights and not just the first layer. The first time I noticed it, it was printing the cabin of Benchy. Z > 1 mm when I finally decided to ask this question. The sound is kind of loud, but that's most likely the resonance in the machine than a symptom, stating it nonetheless.

My setup:

  • Printer: Creality CR-10S
  • Extruder: E3D Hemera
  • Nozzle temp: 205-220 °C
  • Retraction: Initially 5 mm at 40 mm/s, then 0.3 mm, then most recently none
  • Motor Vref: just north of 800 mA. (I've read somewhere that the Hemera motor wants 800 to 1000 mA)

I'm just not sure what could be wrong here. I feel like I checked all the steps and I'm just missing something.

Lux Claridge

Posted 2020-01-17T02:32:45.040

Reputation: 715

1please do a test: move up the nozzle some 2 mm, then force quite some filament out. If it does not click then, you print too close to the bed. – Trish – 2020-01-17T03:08:05.920

1I have that knocking sound too, if i am printing to close to the bed and the extruder cannot push the filament thru the nozzle (or not fast enough as the gcode want to). if it still prints, its fine...ish. i do this on purpose to prefere a minimal to close but better sticking first layer, than a to far away and not so good sticking and not flat surface. – Horitsu – 2020-01-17T06:59:36.403

also you should check every connection and part, that might become lose. my anet a8 made also knocking noises, because the y-rods had some (1mm) free space to move along there axis direction back and forth. (i had to print a fixation with extra screws to close the free space); also some other parts managed it to knocking at some point. (hopefully the new printer arrives tomorrow) – Horitsu – 2020-01-17T07:02:29.233

@Trish The clicking happens at various heights. I first noticed it when the printer was printing the cabin for a Benchy. I've added the info to the question. – Lux Claridge – 2020-01-17T14:07:16.600

Answers

1

I'm still not sure what happened but here's what I did.

I ended up buying a replacement since I thought the motor was seized up somehow. (I had some other issues too that required a replacement anyway.) Removing the heat sink and gear assembly from the old motor was extremely difficult so I assume that the gears somehow didn't link up.

After switching out motors, I was able to print a cube mostly successful.

Lux Claridge

Posted 2020-01-17T02:32:45.040

Reputation: 715

2

A knocking or clicking sound does not imply you have a problem, it implies that you could have a problem; it can be the characteristic of the extruder.


My own designed 2.85 mm filament, 1:4 speed reducing belt driven extruders make clicking sounds while extruding (independent of the layer height), I have verified that no steps are lost and the printer extrudes exactly the requested amount of filament (2.85 mm filament requires a lot more pressure for the same nozzle size, the noise is coming from inside of the metal Bulldog housing, not the stepper adjacent, it is not stepper nor filament skipping noise).


A clicking sound in combination with gears losing position as you describe (or filament skipping back) does mean that the pressure in the nozzle is too big for the extruder to push it through. If the gears loose position, this means that the stepper is not powerful enough to push it through, this means that more current or a more powerful stepper is required (the latter option is due to the design of the extruder not possible). If the filament skips back while the gears are in place the tension/grip to the filament needs to be increased.

In troubleshooting this problem it is best to increase the current to the stepper close to the upper side of the specifications of the stepper and see if the knocking sounds disappear. This should not be a problem for such a priced and tested extruder system, i.e. considering the reputation and quality of E3D this extruder must work out of the box unless you have received damaged components.

0scar

Posted 2020-01-17T02:32:45.040

Reputation: 25 570

1Good answer. I'll say that when it comes to the Hemera, normal operation is exceptionally quiet. I have to check and see the gears are actually moving so this knocking/clicking sound is definitely abnormal. I'll crank up the current and see if that fixes things. – Lux Claridge – 2020-01-17T14:12:31.290

@LuxClaridge Out of curiosity, did you solve the issue? :) Please feel free to add your own answer! – 0scar – 2020-01-21T07:44:23.560

I am not sure what happened. I've replaced the motor (I needed a new one since the housing broke) and everything seems to work now. I can spin the rotor of the old motor so it wasn't seized up like I thought. I think I have enough of a guess to make an answer though. – Lux Claridge – 2020-01-21T14:14:18.210

0

I had a bad connection at my motor that was causing the problem. I soldered direct to the motor and no more problems.

Tim Van Leeuwen

Posted 2020-01-17T02:32:45.040

Reputation: 1