Anycubic i3 Mega layer shifting

0

My Anycubic I3 Mega shifts every layer by a little distance making straight model lean to it's side by an angle.

For example, this white round blob should've been a straight up cylindrical shape, but it leans to the right for some reason. white blob instead of correct cylinder

Don't look at dirty table, it was clean at the start of printing.

When I was printing this model, I prepared it with Cura 3.2.1 slicer.

What could be causing this problem? How it could be fixed?

Update 1: I've tried lowering print speed from 50 to 25 mm/s in Ultimaker Cura 4.4.1. It didn't help. After another test print it seems like it's an X axis problem.

test print closer look

Update 2: Result after setting print speed to 10 mm/s and travel speed to 50 mm/s (same model, same ABS): Low speed => no shifting Even such slight change to print speed as 15 mm/s still produces layer shifting.

VELFR

Posted 2019-12-24T08:33:08.883

Reputation: 101

1Hi and welcome to 3D Printing.SE! Are the belts tight? – 0scar – 2019-12-24T13:50:17.067

@0scar Hi! Thank you. Don't know if the belts are tight enough but not overly. How to know if they are? – VELFR – 2019-12-24T23:51:24.313

Do you have the same problem with a generic gcode file from Anycubic or with G-code produce by another slicer than the one you used? On mine, I use the Slic3r version by prusa (called PrusaSlicer as I had a Prusa printer before) and I just change (reduce) the speed (and some minor details like bed size) from Prusa i3 profile and it works correctly (no displacement between layer). – NeronLeVelu – 2019-12-27T15:12:07.127

@NeronLeVelu I will investigate this possibility. Thanks. – VELFR – 2020-01-07T14:44:11.260

@NeronLeVelu tried lowering print speed from 50 to 25 mm/s in Ultimaker Cura 4.4.1. Didn't help. – VELFR – 2020-01-26T16:02:22.793

I've had seen similar issues where the gear on a stepper motor was loose and causing layer shifting but only when travelling (due to the acceleration between print speed and travel speed). I spent a long time tweaking belts before it occurred to me to check the gears. – p.s.w.g – 2020-01-28T20:49:46.283

The massive reduction for good results hints that something with the carriage mounting seems to be defect. Can you tighten the belt on the Bed? – Trish – 2020-02-01T22:49:05.547

@Trish will try it, but all the belts seem to be tight enough. – VELFR – 2020-02-02T16:22:45.513

No answers