Inconsistent Auto Bed Leveling - Having To Calculate Z Offset For EVERY Print

2

I am having a problem with my Flying Bear P902 3D printer where I have to calculate the Z offset for every single print. I calculate it using this method (and store it in EEPROM) : Link to Stackoverflow post. Then, it will be able to print the first print with the right layer height. But, when I upload a second print afterwards, something goes wrong. It levels the bed and it starts printing too far away from the bed so it is just printing in the air. So, it must some way not have measured right. I checked the Z offset on the control panel and it does say the right offset that I calculated (-2.3).

During the bed leveling, I do sometimes have a problem. It will try to move the bed up to touch the probe, and there is this loud screeching noise, and the bed will not move upward. But, other times it doesn't have this problem. And, I am not sure if this is related to the inconsistent bed leveling.

Printer: Flying Bear P902 (Powered by Arduino & Ramps 1.4) Auto Bed Leveling: BLTouch

Anyway, I have no idea what is causing this problem and it is really annoying to calculate the offset every time. Do you guys have any ideas? Have you guys experienced this problem?

Rosalie W

Posted 2019-07-06T19:21:26.727

Reputation: 373

I would bet when you hear the screeching noise during z-axis movement, it is binding somewhere, and the motor is turning inside of the rod coupler (whatever that thing is called - the part which attaches the motor to the acme threaded rod). Ensure you have some light oil on the bed support rods (the ones which allow movement on the z-axis). This would have an issue on bed leveling when it happens, but I don't think this is causing your overall issue. – Pᴀᴜʟsᴛᴇʀ2 – 2019-07-06T19:33:14.493

I will oil the rods and check them to try to make them turn more smoothly. Do you have any idea what might be causing the inconsistent leveling though? – Rosalie W – 2019-07-06T19:51:52.443

Are you sure it stores the Z offset value? Is M500 enabled in firmware? – 0scar – 2019-07-06T20:47:02.100

Yes, I believe M500 (and EEMPROM) are enabled. And, when checking the z offset value on the lcd screen, it also displays the correct value (even after the 3d printer has lost power). I put some lubrication oil on the rods and they are now running smoothly. I am going to check whether all of the screeching from the non-lubricated rods was one of the issues. – Rosalie W – 2019-07-06T21:21:27.067

Sounds like a mechanical problem with X axis gantry not being square to Z axis. I'm not sure of the mechanical construction of this particular printer though and didn't find good pics to figure it out – R.. GitHub STOP HELPING ICE – 2019-07-07T01:57:36.970

When the bed doesn't move up when requested and you hear noises, the stepper most probably looses/skips steps, this means that you loose the level and requires you to re-level again. – 0scar – 2019-07-07T05:02:57.630

Since I lubricated all of the z axis rods, I have not had this issue anymore. I will still look for it though and see if it doesn't come back (cause then maybe lubricating the rods was only a temporary fix) – Rosalie W – 2019-07-08T21:26:35.437

A screeching noise could also be that the z-axis acceleration value is too high. Lowering it can make vertical movement be more reliable. The problem would only appear on larger Z movements, such as the start of the print. Lubricating the rods could be a good fix, if they were binding, or it could be covering the acceleration problem for a while. – cmm – 2019-09-12T11:18:35.200

No answers