Help diagnose Z-banding

2

The printer is "Monoprice MP Select Mini 3D Printer V2".

This is how my printed fan part looks like:

Printed fan part

These printers are notorious for their Z lead screw assembly (M4 bolt & nut) so I installed flex coupler and aligned the M4 bolt and motor shaft so that the wobble is minimal. It is still there, but I don't think this amount of wobble would produce something like what I experience. Please check out the timelapse video at the end.

I also tightened up Z guide rails (no rattle, very little slop)

Moreover the banding appears to be less pronounced and have alot greater period for vase prints Vase print; extruded ellipse printed along Y axis

(this is extruded ellipse printed along Y axis). I tried:

  1. slowing down print by 50 % - no effect on banding.

  2. monitored hotend temperature with external probe on the heater block (-+5 °C)

The banding appears to be almost exclusively in Y axis direction; for example, the same ellipse printed along X axis: Vase print; extruded ellipse printed along X axis

Now, same ellipse in layered mode (seam side) printed along Y axis Layered print; extruded ellipse printed along Y axis

Andrew Butenko

Posted 2019-07-02T02:34:32.817

Reputation: 165

Please put photos in your question, not as links to external sites. – R.. GitHub STOP HELPING ICE – 2019-07-02T02:37:27.340

Do you know the lead screw's lead/pitch? What is your layer height? Made any calibration adjustments to steps-per-mm? – R.. GitHub STOP HELPING ICE – 2019-07-02T04:01:27.520

the lead screw is just M4 so i guess the pitch is 0.7 (according to http://www.metrication.com/engineering/threads.html ) and layer height is 0.3063. Didn't do any calibration adjustments.

– Andrew Butenko – 2019-07-02T04:42:25.487

it would help if we would know the model - is it a perfect cylinder or can you show it? Also, this is a cantilever printer, make sure that the arm does not raise or lower during printing. – Trish – 2019-07-03T13:44:54.087

@0scar: How does 0.7×200 come up? If the pitch is 0.7 and there are 200 steps, it should be 0.7/200×200=0.7, not 0.7×200. But I'm skeptical that the pitch is actually 0.7. Does M4 mean actual M4 thread in this context, or just 4mm diameter with a metric thread profile shape but some larger pitch and possibly multiple starts? – R.. GitHub STOP HELPING ICE – 2019-07-03T18:23:41.940

It looks like the period is 14-15 layers, which would be 4.2882-4.5945 mm based on the above-reported layer height. – R.. GitHub STOP HELPING ICE – 2019-07-03T18:42:27.653

Answers

2

This differs from the traditional banding as observed from Z wobble induced banding as e.g. explained in this answer.

Your banding patterns clearly seem to form diagonal bands, this is most probably a combination of the lead and the full rotation of the stepper. The most logical explanation is that the layer shifts as a whole in X-Y direction (when seen against the print height, this movement is concentric seen from the top). This means that the next layer is positioned over the previous layer in a concentric pattern. This hints to some sort of defect in your X/Y-plane assembly and should be investigated further.

This is difficult to visualize, but this sketch shows the issue for some layers:

Diagonal Z banding by concentric consecutive offsets

This could be related to the belts of the X and Y-axis, play on the drive pulleys, non-straight lead screw, guide rods with play, play in general, Z-stepper alignment to the threaded rod, etc. Considering the amount of Z-wobble fixes shared by the unofficial MP Select Wiki, the best place to look for is the Z-stepper to lead screw coupling.

0scar

Posted 2019-07-02T02:34:32.817

Reputation: 25 570

It sounds like the lead screw might be bent (thus applying forces in the X and Y directions dependent on its rotational orientation) and like the Y axis belt may have more play/elasticity in it (or X if I read the description backwards). – R.. GitHub STOP HELPING ICE – 2019-07-04T03:55:42.460

2Thank you @0scar! I think your diagnosis is spot on. I checked slop and belts on Y axis before but didn't consider that bed heating cable might snag underneath the rails thus impeding proper Y positioning. I wouldn't expect this effect to have periodic rather than random effect though. but the issue is almost gone after repositioning of the cable. – Andrew Butenko – 2019-07-04T18:28:26.907