Qiditech not working

0

I have a QIDITECH Dual Extruder Desktop 3D Printer which I purchased from Amazon in November 2017.

Until today it has been working fine and I've printed lots of models, today I set it printing and went out, when I arrived home the printing had stopped, the LCD display was still lit but not progressing, no filament was extruding and the extruders and bed had gone cold.

I removed the print from the bed, cleaned it up then tried to print again. The LCD displayed the correct display showing the extruders and bed, but none of them were heating up, the extruder temperatures did not change neither did the bed.

It seems to have developed a fault and I have no clue as to why or how this has happened or what I can do to fix it? I've sent an email to the supplier but so far no reply.

Can anyone help me please?

SPlatten

Posted 2019-05-25T19:58:10.077

Reputation: 227

Will the printer work if you set the bed temperature to 0°C (I.e. no heated bed)? – Mick – 2019-05-26T03:29:21.630

@Mick, Haven't tried that...I was wrong about the extruders not heating they are, its only the bed that isn't heating. – SPlatten – 2019-05-26T06:58:55.163

1are you able to access the board and measure the voltage the printer provides to the bed when you send a print command? Can you disconnect the bed and measure its resistance? it should be non-0 and non-infinite – Trish – 2019-05-26T08:20:45.553

Sorry I don't really want to start dismantling the printer, it may void any warranty. As far as I an concerned its still under warranty... – SPlatten – 2019-05-26T13:24:43.847

In that case, there's not a lot that we can do to help you. Good luck with your warranty claim. – Mick – 2019-05-26T14:59:12.620

No answers