GIMP "color to alpha" is not selectable



Do I have to do something "special" to get the Color -> Color to alpha menu option to work in GIMP? I am trying to convert a background color on a GIF image to transparent by converting the background color to an alpha channel but the Color to Alpha menu option is not selectable.

I've gone through the GIMP documentation and it looks pretty simple :-) I must be missing something rather obvious here!


Posted 2014-03-07T02:56:24.697

Reputation: 343

@NealB I'm running into a similar issue in 2017. My file is already in RGB MODE. Did you ever find a solution?Eric Hepperle - CodeSlayer2010 2017-10-30T11:09:22.883

possible duplicate of Replace black background with a transparent background - There is an answer for GIMP (convert image mode from Indexed to RGB) there.

Takkat 2014-03-07T08:00:32.867

@takkat Thanks, but my problem is not finding the "color to alpha" menu option - the problem is that it is "greyed out" and is not selectable. What are the prerequisites to make this option selectable (e.g. am I missing some sort of add-on)?NealB 2014-03-07T12:44:55.580

5You need to convert your image from indexed (GIF) to RGB first (Image > Mode > RGB), then export as GIF with transparency. Background: Indexed/GIF only supports a single transparent color but not an alpha layer.Takkat 2014-03-07T12:57:05.660



If you imported a GIF file into GIMP, your problem is that your image is in indexed mode. In this mode, most filters and color tools won't work, and be grayed out (up to GIMP 2.8 - expect news on this front on GIMP 2.10).

So, all you have to do there is to go to Image->Mode->RGB, and the Color to alpha menu entry will be enabled.

I don't think that will resolve your problem there: Color to alpha is a sophisticated plug-in to remove a color in a way that if the image is put over a solid background with the same color that was removed, it will look exactly like the initial image again: for that, it does not remove just the places where that color appear in pure form (say (0,0,255) green) - but it makes all colors that take green in their composition partially transparent.

My advice would be to use the Select By Color option to select the color you want to make transparent. If it is a single indexed color, instead of various shades of it, you can set the threshold parameter to 0 - otherwise, experiment with the Threshold and select by controls until you mark all parts of the image you want transparent. After that,just perform Edit->Cut (don't forget to add an Alpha channel to your layer before doing that Layer->Transparency->Add Alpha Channel), and export your image as a GIF file. You won't need to convert to RGB and back to indexed mode if you just want to add alpha, and choose this method - it should work with the image in Indexed Mode.


Posted 2014-03-07T02:56:24.697

Reputation: 3 407


Another option (in addition to @jsbueno's response above) is to open another image file that you know has RGB for its mode (i.e., the Color to Alpha... option is working on that image file already). Then copy your image and paste it as a new layer to the opened image file and you'll see that the Color to Alpha... option will still be available for that layer.


Posted 2014-03-07T02:56:24.697

Reputation: 101

1This is a rather complicated way to do what a single menu entry can do as well, though.Michael Schumacher 2015-06-05T08:50:36.837

@MichaelSchumacher, I was using the single menu entry yesterday and the option was still unavailable for me even after converting the image's mode. Then, I copied the image and I posted it as a layer in a different file and it worked.ayjay 2015-06-05T17:59:22.817

1Then it would be interesting to know why the option wasn't available to you. Have any file where you can reproduce this?Michael Schumacher 2015-06-05T21:02:48.550