Make Blender usable on high resolution screen

46

13

The Blender UI elements are incredibly small by default on high resolution screens on Windows (15" UHD screen). I found the Preferences -> System -> DPI setting which can be set up to 144. This makes Blender usable, but still uncomfortable and difficult on the eyes. Is there a way to make the UI elements even larger?

Sam

Posted 2015-03-11T19:43:09.783

Reputation: 233

2under that there is Virtual pixel mode choose : Double – Chebhou – 2015-03-11T19:45:57.933

Answers

58

To make the UI elements even larger you can choose Double under the Virtual Pixel mode this option is in User_Preferences->system enter image description here

Chebhou

Posted 2015-03-11T19:43:09.783

Reputation: 16 589

A combination of DPI and Double can really do the trick. My native DPI on my 4k 27" monitor is 164 dpi. I set virtual pixel mode to double and DPI: to half of 164, i.e. 82. So that 2 x 82 = 164. I wish you could go higher on DPI though. – user18041 – 2016-12-28T00:17:46.887

This is obsolete by now ? – Nikana Reklawyks – 2018-04-28T13:45:31.913

29

Another thing that is very useful is to hold down Ctrl and the Middle Mouse Button to rescale various panels. This is the same for the 3D Viewport when zooming in or out to view a model. The Outliner Area is the only place I've found so far where this does not function yet.

enter image description here

By pressing the HOME key on your keyboard, you can reset the resized panels back to the original default size.

MarcClintDion

Posted 2015-03-11T19:43:09.783

Reputation: 8 048

Neat trick. I can't figure out how to do this with the keypad on a Surface Book but I was able to do it with an Arc mouse by holding CTRL and "double-tap and holding" the scroll pad. Thanks. Maybe StackOverflow needs to add the ability to have multiple correct answers because both your answer and the answer from @Chebhou are two important pieces of the puzzle. – Timothy Lee Russell – 2016-03-03T03:39:19.320

13

Hover the cursor over one of the panels and hit Numpad + or Numpad - keys on the keyboard to change the size of the font and UI elements.

Denis

Posted 2015-03-11T19:43:09.783

Reputation: 9 537

5

As of the latest version, the setting name has changed.
File > User Preferences
or CTRL ALT U

And the very first entry at the top:
Display: Scale
enter image description here

MostHost LA

Posted 2015-03-11T19:43:09.783

Reputation: 51